Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

At work they have disabled the use of P2P networks such as bittorrent. (Causes too many open connections according to the admins.)

Is there a way to let all programs, except Transmission use eth0 and Transmission use usb0?

share|improve this question

Some programs let you specify what IP address they bind to. Unfortunately, Transmission is not one of them.

If you don't mind using Deluge (another bit torrent client), you could install it. Then open it, Open the Edit menu, click Preferences, then click Network in the sidebar. In the interface field, put the IP address that usb0 has. (You can find this out by runnning ifconfig usb0 in a terminal).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.