Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu 11.10 (Same issue in 11.04 btw) and then I installed Ironhide. I went through the configuration, chose the one with the highest confirmation for my system and tested it:

> Error: Module nvidia does not exist in /proc/modules
> P50 Disabling nVidia Card Succeded

(the spelling error is theirs)

And it changes nothing. I tried other configurations and got worse results. This has really become a major headache. Any solutions?

share|improve this question
Nothing has worked so far. I got rid of the error saying module not found, but the success message is not true. – Musaab Sep 26 '11 at 12:15
You may want to give the newer Bumblebee a go which is more stable. – Lekensteyn Sep 27 '11 at 19:35

try running .. and then reboot

rm /etc/pm/power.d/ironhide-disablecard-on-powerup

After reboot run optirun glxgears. See if it works,

Also I suggest using xorg edgers ppa to get latest module for nvidia

share|improve this answer
You said running .. running what? – Musaab Sep 26 '11 at 11:04
I tried this. It created no change. It still says module not found. – Musaab Sep 26 '11 at 11:53
I installed the nvidia proprietary drivers – Musaab Sep 26 '11 at 11:54

I had the same prob, installed PPA Xorg Edgers, ran apt-get update, apt-get upgrade, reboot and magically it worked.

share|improve this answer
up vote 1 down vote accepted

Apparently the solution to this is the following and with the latest updates to bumblebee, it works:

Install Bumblebee

sudo add-apt-repository ppa:bumblebee/stable

sudo apt-get update

sudo apt-get install bumblebee bumblebee-nvidia

sudo usermod -a -G bumblebee $USER

Reboot or re-login

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.