Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I Just wanted to test the GNOME Shell on Ubuntu 11.10, but I'm getting the following error.

 gnome-shell : Depends: libcogl2 (>= 1.7.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried to install the libcog12 as well, but some packages will be removed, so I canceled because I don't want to crash my Ubuntu again:)

share|improve this question

2 Answers 2

up vote 1 down vote accepted

This problem has been solved by updates.

decent@decent:~$ gnome-shell --version
GNOME Shell 3.1.92

decent@decent:~$ sudo apt-get install gnome-shell
[sudo] password for decent: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
gnome-shell is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

decent@decent:~$ uname -a
Linux decent 3.0.0-11-generic #18-Ubuntu SMP Tue Sep 13 23:38:01 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

decent@decent:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu oneiric (development branch)
Release:    11.10
Codename:   oneiric
decent@decent:~$ 
share|improve this answer

discussed here as a known issue. wait a few days http://ubuntuforums.org/showthread.php?t=1848618

share|improve this answer
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Marco Ceppi Sep 23 '11 at 11:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.