Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is it possible to disable the GNOME (version 2) global keyboard shortcuts for a specific application?

I'm using the IntelliJ IDEA Java IDE under Ubuntu however some of the IDEA default keyboard shortcuts conflict with the GNOME shortcuts (e.g. Alt+F1, Ctrl+Alt+ or Ctrl+Alt+). I really don't want to change the conflicting shortcuts within IDEA. I need to use the default keymap for "compatibility" reasons.

I'm thinking of some kind of proxy command that redirects every keyboard activity to the application when it has the focus. Something like kbdproxy idea.sh.

share|improve this question
    
Hi, have you found a solution? I'm going crazy for this problem with IDEA. –  Roberto Leinardi May 19 '13 at 15:17
    
@RobertoLeinardi Unfortunately no :( –  Sven May 20 '13 at 15:41

2 Answers 2

The latter two for workspace switching is possible to be disabled , download and install gconf-editor , locate this entry:

move_to_workspace

enter image description here

And leave them empty should work.

share|improve this answer
    
These two shortcuts were just examples. There are others that conflict, too. I don't think it's a good solution to disable the conflicting GNOME shortcuts :-/ I still want to be able to use them outside of the application. –  Sven Oct 13 '11 at 13:01
    
@Sven , You probably want to fire a bug report to the developers , ask them to grab all key events in X11. –  warl0ck Oct 13 '11 at 15:05

I posted this question in stackoverflow expecting loads of excellent answers but got none.

My personal solution is currently:

  1. Install very light weight wm like 'twm': (sudo apt-get install twm)

  2. Kick off a concurrent X session with no wm: xinit /usr/bin/xterm -- :2

  3. Switch to new X session: control-alt-F8

  4. Start twm in xterm within new session: twm &

  5. Run program, enjoy programs shortcuts and be happy, switching back to other X session with control-alt-F7

share|improve this answer
    
I also had to change /etc/X11/Xwrapper.config to say "allowed_users=anybody" in order for step 2 to work. –  user467257 Feb 10 at 15:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.