Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I have an old server which I want to use as Mercurial repository host. apt-get install mercurial gives me v0.9, which is stoneage and without Windows filename workaround, which I rely on.

I've downloaded the v1.9 source and tried to build it but I end up in a web of depedency conflicts. Is it any way I can get v1.9 of mercurial to run in an Intrepid installation (kernel 2.6.24-19-generic)?

If not, how about 1.1 (the first one with Windows filename workaround)?

share|improve this question
2  
You'll likely need to upgrade or satisfy all the dependencies. Karmic has been EOL'd since April –  Marco Ceppi Sep 22 '11 at 22:31

3 Answers 3

Short answer: No.

Long answer: Nada.

First, 9.10 has reached its "EOL", or "End Of Life" - you'd be better off installing 10.04 or 8.04, they're still supported.

With that being said, you could try to enable the backports repository - (more on that here) and see if it's got Mercurial 1.9.

share|improve this answer

I made it! I actually tried to upgrade the release first with do-release-upgrade, but that failed. What did succeed in this process however, was upgrading Python using aptitude (apt-get failed). This lead me to try and compile the source for mercurial agaian, and voila!

So aptitude install python-dev did the trick, followed by make install

To be honest, I'm not quite sure which apt-sources I used at that moment, but I think it was Hardy. Guess no one else will try this after me anyway, so... well anyway :)

share|improve this answer

You can get Mercurial 1.9 from the PPA for it. To add it, pop open a terminal and type:

sudo add-apt-repository ppa:mercurial-ppa/releases

Once that's completed, run a quick update.

sudo apt-get update

Then you can now install the latest Mercurial using apt-get.

share|improve this answer
1  
It looks like they only have installs for hardy, lucid, maverick, and natty. Not Karmic since it's been EOL'd for a while. –  Marco Ceppi Sep 22 '11 at 22:30
    
@Marco Will it not work though? I have used older packages before and such –  Simon Sheehan Sep 22 '11 at 22:32
2  
These are new packages on older systems. The dependency hell will still exist. –  Marco Ceppi Sep 22 '11 at 23:43
    
@MarcoCeppi Ah okay, oops. –  Simon Sheehan Sep 22 '11 at 23:54
    
add-apt-repository: command not found :-P Seems like it was first introduced in Karmic. Oh well... Look's like I'm heading for an upgrade –  Nilzor Sep 23 '11 at 6:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.