Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got the visual boy advanced emulator 1.8.0 but it runs at 125% - 200% too fast, and if I throttle it to 100% the sound goes real slow.

share|improve this question
    
Which version of vba are you using? –  N.N. Sep 22 '11 at 21:28
    
1.8.0, the one thats on the software centre. –  neilh Sep 22 '11 at 21:32
    
VBA-M (a VBA fork), which you can install via PlayDeb, works perfectly in my system. It's being actively developed AFAIK. You should try it. –  Alfredo Hernández Jun 9 at 20:40

2 Answers 2

This has been a launchpad issue for the last few versions of this particular emulator.

Suggestion would be to use an alternative emulator such as Mednafen (install from software center)

share|improve this answer

There is an alternative called VBA-M which doesn't have this problem and features easy-to-use GUI. You can get a pre-compiled package from PlayDeb (as of April 2014, available for any Ubuntu version between 10.04 and 14.04). It should work in older hardware as well.


Alternatively, you can try RetroArch with VBA core, which appears to be based on newer versions of VBA-M. Pre-compiled packages are available for Ubuntu 12.04 and newer in this PPA. The package name for emulator is "retroarch" and VBA core is either "libretro-vba" or "libretro-vba-next", depending on your Ubuntu version. (In this PPA, except for Ubuntu 12.04, the support for old Ubuntu versions are dropped as soon as new Ubuntu version is released.)

Its GUI is rather primitive and doesn't let you customize keyboard settings. To change the key mappings, edit the config file located in ~/.config/retroarch/retroarch.cfg (created automatically after run once) directly using any text editor.

RetroArch's default OpenGL renderer requires fairly new video card so it may fail to function. (It worked well in my newer PC with NVidia video but not on my older Intel one) If that's the case for you, create a new file in ~/.config/retroarch/retroarch.cfg (delete it first if this file already exists; create directories if they don't exist) and put the following line in the file:

video_driver = "sdl" (or video_driver = "xvideo")

and start the emulator directly from the command line (because there are no GUI outside of GL renderer):

retroarch --libretro /usr/lib/libretro/vba_next_libretro.so /PATH/TO/ROM.gba

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.