Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do I stop D from showing the Desktop?

When I RDP (xrdp) or VNC (built-in or x11vnc, client-side UltraVNC), pressing 'D' shows the desktop.

Please tell me how to remove this binding.

share|improve this question
    
I have had the exact same thing happen - curious to see the answer. –  Jayson Rowe Sep 22 '11 at 19:12

2 Answers 2

up vote 4 down vote accepted

I've had the same thing happen. Here's what I do to solve:

  • Go to System menu -> Preferences -> Keyboard Shortcuts
  • Under the Window Management catagory, select the entry for Hide all normal windows and set focus to the desktop and press the Backspace key to clear the entry
  • Restart the vncserver session

An alternative option is to use the command line within the session. Paste the following in the terminal:

gconftool-2 -t str -s /apps/metacity/global_keybindings/show_desktop ""
share|improve this answer

As an alternative to the above answer, what I did in my remote session was edit the dconf for ubuntu 12.10 on the gnome-fallback ui.

open Applications\System Tools\dconf Editor

navigate to:

org\gnome\desktop\wm\keybindings

then change the "show-desktop" keybinding to "[]", obviously without the quotations.

I then rebooted the machine, but you probably could just restart the service, and everything worked.

share|improve this answer
    
Finally, someone talking about gnome-fallback! This problem is everywhere on askubuntu, but Jeremy's solution is one of the only ones that works with the fallback ui. [Edit: Worked for me on 13.04] –  Eric Sep 15 '13 at 1:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.