Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I plug in HDMI cable in my GeForce video card in order to watch movie on my TV in Multimedia — Sound — Video preferences window I see HDMI and built-in analog device. When the later gets higher priority then the former I can hear movie sound (playing through Dragon Player) from PC speakers. When I reverse priority order I expect TV to play movie sound (which is what I really want) but get no sound at all.

Any suggestions how to get sound through HDMI? I've searched the forum and found lots of questions concerning HDMI audio, but couldn't find solution working for me. At least: my S/PDIF device is unmuted in alsamixer.

UPD The output of most some commands may help.

$ uname -r
2.6.38-8-generic

$ lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation GT215 [GeForce GT 240] (rev a2)

$ aplay -l
**** Список PLAYBACK устройств ****
карта 0: Intel [HDA Intel], устройство 0: ALC883 Analog [ALC883 Analog]
  Подустройства: 1/1
  Подустройство №0: subdevice #0
карта 0: Intel [HDA Intel], устройство 1: ALC883 Digital [ALC883 Digital]
  Подустройства: 1/1
  Подустройство №0: subdevice #0
карта 2: NVidia [HDA NVidia], устройство 3: HDMI 0 [HDMI 0]
  Подустройства: 1/1
  Подустройство №0: subdevice #0
карта 2: NVidia [HDA NVidia], устройство 7: HDMI 0 [HDMI 0]
  Подустройства: 1/1
  Подустройство №0: subdevice #0
карта 2: NVidia [HDA NVidia], устройство 8: HDMI 0 [HDMI 0]
  Подустройства: 1/1
  Подустройство №0: subdevice #0
карта 2: NVidia [HDA NVidia], устройство 9: HDMI 0 [HDMI 0]
  Подустройства: 1/1
  Подустройство №0: subdevice #0
share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 15:29

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
OP are you still looking for an answer? If so, you may need to repost your question as this is flagged for closure. Regards, –  Ringtail Mar 20 '12 at 17:32
    
Try looking at my answer here, but disable the analogue instead of HDMI and see if that helps. –  Tom Brossman Apr 3 '12 at 20:22

Browse other questions tagged or ask your own question.