Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently purchased an HP Pavilion with a Radeon HD 6470M card that is not supported. Until I found that out I reinstalled Ubuntu several times and eventually got some basic drivers to work. Due to a software I installed, I made some tweaks and broke it again, and now I can't install Ubuntu.

To try fix the problem I loaded Win7 (I'm dual booting), and reformatted (slow) the Ubuntu partition. I subsequently lost the boot for Win7, which I fixed.

However, every time I try to install Ubuntu 11.04 it either displays a black screen (doesn't even go as far as letting me choose to "use ubuntu without installing"), or stops loading saying that it has "Bad target number". I even tried the Alternate CD, which installed Ubuntu but will not go past the GRUB (even when I use "nomodeset").

I have absolutely no idea what else to try.

Any help would be GREATLY appreciated.

share|improve this question
add comment

3 Answers 3

up vote 2 down vote accepted

I managed to work out the problem.

The top row of the keyboard has the brightness and volumes, etc., keys as primary, and the Function keys (F1, F2, etc.) available when pressing the "Fn" key. So I went into the BIOS and switched them around. It turns out the the LiveCD did not like that. It obviously causes a hardware conflict, which for some reason manifests as a Radeon error (I have no idea why).

In any case, it works now.

Hope this helps people trying to reinstall Ubuntu: Make sure your BIOS is set to factory settings!!!

share|improve this answer
add comment

Try connecting an external monitor. Ubuntu did not appear on the laptop, but did appear on the external monitor. No clue why !

share|improve this answer
add comment

Maybe it's just the background-light of your screen that is not activated!? I had such a problem with an acer-Laptop and Natty (bug in kernel): If so, you can use a strong torch to see a little bit and start a terminal.

You have to set the backlight from terminal:

setpci -s 00:02.0 F4.B=60

Look here for workaround: Backlight workaround

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.