Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use ubuntu 10.10 and installed the Eclipse indigo from the official eclipse website. It's a java editor (not CDT) and characters on the content assist popup are not readable.

enter image description here

Is there any solution?

share|improve this question
add comment

5 Answers 5

After little research:

gedit ~/.gtkrc-2.0

paste and save:

style "eclipse_fix"
{
    base[ACTIVE] = shade(0.7, "#F2F1F0")
}

class "GtkTreeView" style "eclipse_fix"

Then you must logout or change your style in order to reload new settings.

share|improve this answer
    
I compiled an article which summarizes the topic. –  JJD Jul 28 '12 at 15:20
add comment

Let me to cite answer for 12.04

Simply edit the file /usr/share/themes/Ambiance/gtk-2.0/gtkrc search for

base[ACTIVE]      = shade (0.94, @bg_color)

change the shade percentage from 0.94 to whatever visible like 0.54

base[ACTIVE]      = shade (0.54, @bg_color)

then it works.

share|improve this answer
add comment

Your screen capture looks what I get. It's OK for me but if it's no good on your screen, you should be able to change the colours by going to Window > Preferences > General > Appearance > Colors and Fonts and changing either or both of 'Content Assist background color', 'Content Assist foreground color'. But it doesn't look like you can separately control the colours for highlighted and other lines.

share|improve this answer
add comment

When using the default Ubuntu 12.04 Ambiance colour scheme I changed tooltip background colour to tooltip_bg_color:#7F7F7F allowing inspector popup windows to show visible text:

sudo gedit /usr/share/themes/Ambiance/gtk-2.0/gtkrc

gtk-color-scheme = "base_color:#ffffff\nfg_color:#4c4c4c\ntooltip_fg_color:#ffffff\nselected_bg_color:#f07746\nselected_fg_color:#FFFFFF\ntext_color:#3C3C3C\nbg_color:#F2F1F0\ntooltip_bg_color:#7F7F7F\nlink_color:#DD4814"

Log out of ubuntu and log back in to see the effect

For more of a Ubuntu experience try using #DA8C6D as the new background colour.

share|improve this answer
add comment

This might be a dumb answer but... is it possible that the font color is set to white so you can't actually see anything? I guess you can change the font color somewhere in in Preferences.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.