Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Fresh Beta install on Aspire 5741 (NEW70) - network ok

After installation, run update (485 updates) - install completes ok

After update and reboot, Network Manager fails to open. Unable to connect to LAN.

Though my hardware, both WLAN and LAN, are still recognised, however network icon disappears from taskbar, and I am unable to launch NM-APPLET both from menu and terminal.

Error "missing folder" in terminal

Tried both the amd64 and i386 versions.

Ubuntu 10.10 runs fine on laptop.

share|improve this question
11.10 is a beta so any problem you get is likely to be solved with the final release. You need to inform the maintainer of the package if you want this fixed (ie -> launchpad ). – Rinzwind Sep 21 '11 at 10:00
Please take a look at this link and follow the instructions given there when you have issues with Alpha/Beta releases – Nitin Venkatesh Sep 21 '11 at 15:34
You probably got bit by the ca-certificates bug, see this discussion for help: – Jorge Castro Sep 21 '11 at 15:53
@Mark Greenwood if that worked for you, you may post as an answer and accept is ;) – Achu Sep 21 '11 at 16:44
Don't edit your question body to have the answer. Instead just use the "Your Answer" box to enter what resolved it for you. – Marco Ceppi Sep 21 '11 at 16:51
up vote 1 down vote accepted

The same happened to me this morning. You can activate yout network like this:

sudo service network-manager stop
sudo dhclient eth0
sudo dpkg --configure -a

After that you can start a partial upgrade:

sudo apt-get dist-upgrade -f

If this doesn't work look here:


share|improve this answer
It works for me. Thank you. :) – kv1dr Sep 23 '11 at 10:35

You may as well try to run this command from the terminal as this worked for me:

sudo apt-get install --reinstall libnss3:i386 libnss3
share|improve this answer

I'm not sure what you have tried, but you could run nm-applet from the run dialogue, and it should start your networking icon. If it does not start, run:

sudo start network-manager
nm-applet & disown

In a terminal.

Edit: Jorge pointed you to the right place.

share|improve this answer
I get that error: mark@nexar-laptop:~$ sudo start NetworkManager [sudo] password for mark: start: Unknown job: NetworkManager mark@nexar-laptop:~$ sudo start network-manager start: Job is already running: network-manager mark@nexar-laptop:~$ sudo nm-applet & disown [1] 2018 mark@nexar-laptop:~$ nm-applet: error while loading shared libraries: cannot open shared object file: No such file or directory – Marc Boisvert Sep 21 '11 at 15:52
@MarkGreenwood: uh oh... You upgraded libnss3... – RolandiXor Sep 21 '11 at 15:54
So what am I supposed to do ? :\ – Marc Boisvert Sep 21 '11 at 15:55
@MarkGreenwood follow the forums link I linked to on top. – Jorge Castro Sep 21 '11 at 16:00
@JorgeCastro So I copied to x86_64-linux-gnu and I rebooted. Now am I supposed to delete it ? I don't know what to do... Sorry I'm really not good in Ubuntu :( – Marc Boisvert Sep 21 '11 at 16:06

According to the link that Jorge Castro provided - SOURCE page 2 you can follow the advice given on post #14 or post #13

According to Post #14 - you will have to boot off a live disc, mount the Ubuntu partition, chroot into it and then perform updates, the new updates contain the fix for the ca-certificates bug. For a detailed how-to please take a look at the post.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.