Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I built a new computer a couple months ago and installed Windows 7 and Ubuntu 10.04 on it. It has a Gigabyte motherboard which has a Realtek 8111d onboard network card.

In Windows, networking works fine. If I switch to Ubuntu, I have no network connectivity whatsoever, and in order to boot Windows, I have to leave my computer off for a minute or two in order for networking to work after having Ubuntu running.

Since Ubuntu by default installs the r8169 driver for my network card, I've tried installing the r8168 driver, since that's supposedly the correct driver for my card. It hasn't helped.

I installed 10.10 today (a fresh install), hoping that'd fix the problem. It didn't, so I checked lsmod, which showed the r8169 driver installed again. So I try installing the r8168 driver (according to these instructions) and it installs without any problems. I shut off my computer and unplug it, then go do some homework for 10 or 15 minutes. I come back, hoping the combination of the new driver and being powered off for a while have fixed it. Alas, no luck.

I would post the outputs of various commands, but because of the above issues, it's rather difficult. However, if they're absolutely necessary, I can do so.

So, any help that could be provided would be great.

share|improve this question

2 Answers 2

Try this (from http://ubuntuforums.org/showthread.php?t=538448)

If your ethernet cable is connected at boot time and you are experiencing the no link problem, try this:

  • Shutdown, power down.
  • Unplug your host (this cuts power to the card if wake-on-lan power is maintained).
  • Wait 15 seconds.
  • Plug in.
  • Boot ubuntu.
share|improve this answer

There are two guides:

http://www.twm-kd.com/linux/realtek-rtl81688111e-and-ubuntu-linux/

http://www.jamesonwilliams.com/hardy-r8168

I actually prefer the first one. Works fine with latest Realtek driver r8168-8.026.00.tar.bz2, but only with linux kernel 3.0. 3.1 and 3.2 will complain about "invalid module".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.