Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 11.04 32bit on a Lenovo E520 with a Intel WiFi Link 1000 BGN device.

Though Windows7 can connect itself to WiFi as well as being able to see other WiFi networks, Ubuntu can not.

When I went to additional driver, no drivers are on the list.

How can I connect my laptop to wireless network and use drivers in Ubuntu?

share|improve this question
add comment

1 Answer

I'm a bit late for this, but if someone arrives here looking for this question, here is the answer. It worked for me in Ubuntu 11.04 and 11.10.

Open a terminal and type

sudo modprobe -r acer_wmi

You should be able to connect to the wireless till next reboot.

  • Making the change permanent

Edit the file /etc/modprobe.d/blacklist.conf with your favorite text editor, ie gksu gedit /etc/modprobe.d/blacklist.conf, and add this line at the end of the file

blacklist acer_wmi

Reboot and you’re done.

Please note: This applies to wireless card having rtl8188ce chipset. You can view that by typing lspci in a terminal and searching for the entries respective to Network Controller.

The problem should be solved for Ubuntu 12.04.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.