Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop with Ubuntu 10.04.

My daughter was playing with the keyboard on the login screen, and it seems she activated some assistive technologies because now the screen is split vertically and the right side shows a magnified version of the left side. Plus, there's a screen keyboard.

The way the screen is split makes it impossible for me to disable the assistive stuff from the toolbar at the bottom, since I can only see part of it.

I don't know if it's a bug or what, because I'd guess I could see the entire bar on the right (magnified) side just by moving the mouse there, but I can't.

I can't even type on the login screen, nor use the on-screen keyboard... Good thing I have auto-login activated, so I can still use the computer, but I can't switch users.

So, does anyone know how to get the normal login screen back?

share|improve this question
add comment

4 Answers

up vote 5 down vote accepted

From: gdm - On screen keyboard malfunctioning on login screen - Ask Ubuntu

Disable screen magnifier in GDM:

sudo -u gdm gconftool-2 /desktop/gnome/applications/at/screen_magnifier_enabled --type bool --set false

Disable on-screen keyboard in GDM:

sudo -u gdm gconftool-2 /desktop/gnome/applications/at/screen_keyboard_enabled --type bool --set false
share|improve this answer
    
Awesome, thanks a lot! –  Ivan Oct 12 '10 at 2:16
add comment

Try resetting gdm to the default values

sudo -u gdm gconftool-2 --recursive-unset /desktop
share|improve this answer
    
I'm sure this would work too, but Andrew's solution doesn't reset all configurations. Thanks anyway! –  Ivan Oct 12 '10 at 2:17
add comment

Have you trying disable it at Preferences -> Assistive technologies ? Another way would be to disable it from start up on Preferences -> Start Up Applications and untick the option relative to Assistive technologies.

share|improve this answer
    
It wouldn't work because those happen after login, but thanks for the thought. –  Ivan Oct 12 '10 at 1:46
add comment

In 11.10 start onboard from terminal, press the bottom right button that has three lines over it (Snippets), press preferences (left side). From Onboard preferences un check "Show Onboard when unlocking the screen".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.