Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I was installing the application (tracker-0.10.24) I've got this message:

Package requirements (glib-2.0     >= 2.26.0
                      gobject-2.0  >= 2.26.0
                      gio-unix-2.0 >= 2.26.0
                      dbus-1       >= 1.3.1
                      dbus-glib-1  >= 0.82) were not met:

No package 'dbus-1' found
No package 'dbus-glib-1' found

I can go to ubuntu packages and install them step by step, but I think here's should be more convenient way. How to install all these libraries?

share|improve this question
    
Assuming you are using apt, try running apt-get install -f <package-name>. –  David Kuridža Sep 19 '11 at 14:29
    
For example what should I write for glib: 'apt-get install -f glib-2.26.0', is it right? –  megas Sep 19 '11 at 14:34
add comment

1 Answer 1

up vote 9 down vote accepted

Presumably this is an error from a configure script?

The error is referring to pkg-config package files. These do not correspond one-to-one with Ubuntu/Debian package names (since they are not Debian or Ubuntu specific).

In this particular case, the dbus-1.pc file is found in the libdbus-1-dev Ubuntu package, and dbus-glib-1.pc is found in the libdbus-glib-1-dev Ubuntu package. Installing those two should satisfy the dependencies of that configure script check.

share|improve this answer
    
1.You're right 2. I've installed libdbus-1-dev and dbus-glib-1-dev and then I've got another errors 'No package 'sqlite3' found No package 'uuid' found'. I've tried to install them too: 'apt-get install sqlite3' and 'apt-get install uuid', it installed successfully but didn't help. How do you know which exactly package to install? –  megas Sep 19 '11 at 15:07
2  
You can easily do package searches using apt-cache search. Searching for sqlite3 shows libsqlite3-dev as one of the answers, so that is probably what you want. Similarly, you probably want uuid-dev. Now given that tracker has already been packaged in Ubuntu, one option would be to install the build requirements for that package: that should easily be enough to let you build it from source. You can do that using the command apt-get build-dep tracker. –  James Henstridge Sep 20 '11 at 0:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.