Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

To make my question as simple as possible, I'll start with showing my desktop, so that I don't need to describe everything in words:

Basically this is how I have been using Ubuntu 10.04 since it's been released: all ubuntu/gnome panels erased and only AWN (Awant Window Navigator) running on the left side of the screen.

How possible is it to get as close to this look as possible in Ubuntu 11.10 without downgrading to gnome 2?

Possible solutions I can roughly think of, but am not sure how to accomplish them:

1) Use Unity interface, hide the Unity launcher and try to get used to the necessary top panel (I don't think that can be erased, or can it?)

2) Use Gnome interface and somehow erase all the panels/launchers?

share|improve this question
    
Remove/rename the Unity binaries and create symlinks to empty programs? –  RobinJ Sep 19 '11 at 15:04
    
@RobinJ: Wouldn't it be easier to just disable Unity? It is a Compiz plugin after all. –  Nathan Osman Sep 28 '11 at 6:38
    
Link to the wallpaper? –  Ravi Jul 31 '12 at 7:10

6 Answers 6

up vote 3 down vote accepted

enter image description here

Well almost - once this bug is resolved then the top pesky nautilus menu-bar will disappear!

How to...

  1. Some prerequisites - install gnome-session-fallback & avant-window-navigator.
  2. Logout and login with the new session "gnome classic"
  3. start awn-settings and configure awn as you need to - ensure you tick the box to start awn automatically.
  4. Run gnome-session-properties and add a new item compiz --replace
  5. Edit /usr/share/gnome-session/sessions/gnome-classic.session and remove "gnome-panel"
  6. Edit /usr/share/gnome-session/sessions/gnome-fallback.session and remove "gnome-panel"
  7. Logout and login
share|improve this answer
1  
how safe is it to use gnome-session-fallback? will it be maintained and supported properly? the fallback part sounds like it's kind of a "temporary, weak solution" –  Richard Rodriguez Sep 19 '11 at 19:43
    
Its as safe as the gnome 3 guys support it... its the standard fallback session for computers that cannot support the full gnome 3 session. So very similar as the "unity 2d" fallback for standard Unity. –  fossfreedom Sep 19 '11 at 20:17
    
Thanks, this really looks like the best solution, so I've accepted your answer, but could you please further explain what do the steps 4, 5 and 6 do? I think I understand the steps 5 and 6, but I'm not getting the step 4. Thanks! –  Richard Rodriguez Oct 10 '11 at 0:47
    
When you remove the panels - compiz stops running... therefore, using compiz --replace just gets compiz to startup correctly. 5 & 6 just stops gnome-panel being started on logon. –  fossfreedom Oct 10 '11 at 20:30

RiMMER, your desktop screenshot looks almost exactly like Unity except for a missing top-panel.

To change the default Unity to something more similar to your screenshot first install CompizConfig Settings Manager (CCSM). Click the "Ubuntu Unity Plugin" button.

  • under the BEHAVIOR tab, find where it says "Hide Launcher" and change the setting to "Never."

  • under the EXPERIMENTAL tab, find where it says "Launcher icon size" and shrink the icon size to a size of your choosing.

  • to my knowledge it is not possible to "delete" the top-panel so I suggest you just learn to live with it. It is non-intrusive, not very big, and actively participates in application functions (e.g., application menus and maximized-window-controls).

share|improve this answer
    
It may look similar, but it doesn't behave the same. AWN is not nearly as dictatorial as Unity as far as configuration goes. You can put it anywhere, and even have multiple panels if you want. I use it with Gnome Classic and Compiz, and like it much better. –  Marty Fried Mar 3 '12 at 21:41

I really dislike the new gnome user interface. I love the old classic look and feel so I went back with the help of the following question:

Then I alt + right clik each of the panel (top, right and bottom) and set their properties to autohide and once more my mind is at ease. Thus far, no errors and desktop makes sense again.

share|improve this answer

You could add insights to this bug that is very related to the top panel issue. https://bugs.launchpad.net/unity/+bug/853865 Don't forget to press "affects me too"

share|improve this answer
    
Who's talking about multiple monitors? Offtopic. -1 –  Jo-Erlend Schinstad Sep 19 '11 at 18:44
    
It's about the possibility to hide the panel. –  alex Sep 23 '11 at 19:19

You cannot remove the Unity Bars (you can in Unity 2D, but I wouldn't advise that). Your best bet is to install GNOME 3 and remove the panels, or create your own custom session.

To use GNOME 3, choose GNOME Classic from the login screen (not GNOME Shell) and alt+right click on the panels to get the regular menu (for editing).

share|improve this answer
    
Any idea how can I do that? I tried installing gnome shell and I couldn't find out how to erase all the panels to have only a clean desktop. –  Richard Rodriguez Sep 19 '11 at 13:56
    
@RiMMER: Use GNOME Classic. GNOME Shell will be the same deal as Unity. –  RolandiXor Sep 19 '11 at 13:59
    
Except that Gnome Classic cannot be run in 11.10. They have a similar looking replacement though, but it doesn't work the same way. –  Jo-Erlend Schinstad Sep 19 '11 at 18:43
    
@Jo-ErlendSchinstad: that is not completely true. The new GNOME Classic is the same GNOME-Panel etc, just that they have had some changes. It is the same desktop environment with the same applications. –  RolandiXor Sep 19 '11 at 20:24
1  
@Jo-Erlend Schinstad: Gnome Classic acts a hell of a lot more like Gnome 2 than the XFCE you often recommend. It has the same sort of UI, many of the same standard applets, etc. –  Marty Fried Mar 3 '12 at 21:45

You might also try installing xubuntu, install AWN and finally removing the XFCE panels. You will get something that nicely matches your desired end state with little effort.... you could do the same with lubuntu but personally I find Lubuntu's font rendering unacceptably poor.

Perhaps the nicest approach though is to use Gnome Classic... disable Unity Menu from with CCSM and the set AWN or Docky or Cairo Dock or similar or pick up the desktop UI load. Great font rendering, Nautilus Desktop plus....all work nicely.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.