Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Logitech MX Anywhere wireless USB mouse which works very well with Ubuntu. However, I would like to disable the touch pad when this mouse is connected. I keep hitting the touch pad with my wrist or thumb and cause the mouse to move to another part of the screen. I am constantly fixing typos.

I've had this problem since I installed Ubuntu 9.10. I'm not sure if it is because the biometrics is part of the touchpad, the way the device is built into the system, or the BIOS which does not let me disable it.

share|improve this question
    
This issue seems to be discussed here: ubuntuforums.org/showthread.php?t=961324 –  outofstep Oct 25 '10 at 12:54
add comment

3 Answers

Definitely not the only way, but one way to do it would be to install gpointing-device-settings and check the "Disable while any other devices are connected" checkbox in the "General" tab for your touchpad.

share|improve this answer
    
When I installed gpointing-device-settings on my notebook, I do not see the General tab for Touchpad. Touchpad is not listed as a device. For me it is FSPPS/2 Sentelic FingerSensing Pad. When I connect a USB wired mouse, the wired mouse is listed. But I cannot disable the FSPPS/2 device. –  George Oct 14 '10 at 10:04
add comment

My preferred way is to never use the touchpad and disable it in the BIOS. An added bonus is it's a security feature; it will effectively confuse and disorient anyone attempting to use your laptop.

share|improve this answer
    
I looked into that as well. My BIOS from Phoenix does not have the option to disable the touchpad. The fingerprint reader is part of the touchpad device, and there is no option to disable the fingerprint reader there either. –  George Oct 14 '10 at 10:09
add comment

You can disable the click of the Synaptics TouchPad without disabling the mouse movement. In my experience with such device, it was annoying only when touching it was actually sending a "click" message, effectively moving the text editing cursor away, scrambling all my typing. You can disable the Touchpad clicking, requiring that you press one of the buttons to effectively send a click. You should find this under the Mouse options in the Preferences menu under Ubuntu.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.