Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have install Bugzilla according to How do I install Bugzilla?

I can't access the files. apparently /usr/local/

drwxr-xr-- 16 www-data www-data 4096 2011-09-19 09:30 bugzilla-4.0.2/

The link from /var/www/

lrwxrwxrwx  1 www-data www-data   25 2011-09-18 13:53 bugzilla -> /usr/local/bugzilla-4.0.2/

When browsing to: http://localhost/bugzilla I get :

Forbidden

You don't have permission to access /bugzilla on this server.

Apache/2.2.14 (Ubuntu) Server at 192.168.0.22 Port 80

How to fix it please?

share|improve this question
    
I added this to my apache2.conf file Alias /bugzilla/ /var/www/bugzilla <directory /var/www/bugzilla> Addhandler cgi-script .cgi .pl Options +Indexes +ExecCGI +FollowSymLinks DirectoryIndex index.cgi AllowOverride Limit </directory> –  Saariko Sep 19 '11 at 9:50
    
Oh, and the apache error_log file might well tell you more about the problem. –  ed. Sep 19 '11 at 17:44

1 Answer 1

up vote 1 down vote accepted

In order for the link to work, www-data will have to have the following permissions:

rx on /usr, /usr/local, /usr/local/bugzilla and any sub-folder

r on any files within /usr/local/bugzilla

Oh, and the apache error_log file might well tell you more about the problem.

share|improve this answer
    
Do I really need X on /usr? why is the link than? This exposes all of my subfolders for execute permission. Isn't it too much? –  Saariko Sep 20 '11 at 6:42
    
To follow a symlink a user needs to be able to navigate to the folder in question, so needs X all the way. If you don't like this then you could use mount (-o bind, from memory) to mount your folder on top of /var/www/bugzilla. –  ed. Sep 20 '11 at 8:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.