Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My laptop was working perfectly, but suddenly today I turned it on and after GRUB, the Plymouth splash flashed and then the screen went black with a blinking cursor. After blinking like 6 times, the cursor disappears and the screen stays completely black. Ubuntu won't boot after that and the computer is non-responsive to Ctrl+Alt+Del, so I have to reboot by holding the power button and then turning it back on.

I tried using the Recovery Mode to see if it was a problem with X or whatever... But it always seemed to crash when it was going to ask me to login. I did some research on the Internet and then tried holding Shift while booting up and then pressing 'e' when GRUB showed up. I then removed "quiet splash" and tried with "text" there. Computer booted up and I didn't get any errors. Logged in with my user and password, and then did a manual startx. After that the laptop starts and runs perfectly, as I'm using it right now to write this message.

I think the problem is something in gdm, but I don't know what. I thought maybe it was a problem with Plymouth, but I imagine failsafex from Recovery Mode would skip Plymouth and just send you to log in.

Does anybody have any idea how to get gdm to work again? Or any idea what could be wrong with it?

share|improve this question
Do you see any relevant (gdm or X related or other errors) entries in the logs? (/var/log/syslog, /var/log/Xorg.0.log) – arrange Sep 19 '11 at 7:51
I found this on /var/log/syslog gdm-binary[808]: WARNING: Unable to load file '/etc/gdm/custom.conf': No such file or directory. And this gdm-binary[808]: WARNING: Unable to find users: no seat-id found And there seems to be quite some other errors... gdm-simple-slave[908]: CRITICAL: Error while compiling regular expression DBUS_SESSION_BUS_ADDRESS=(.+)#012DBUS_SESSION_BUS_PID=([0-9]+) at char 0: unknown option bit(s) set It seems like those are the errors that seem to repeat the most, and a couple others. – TanoPiloni Sep 19 '11 at 16:18
up vote 3 down vote accepted

If plymouth displays but gdm fails to start up at boot, the system may have left you on a blank VT (virtual terminal) and the end of the boot sequence. You can try pressing Alt+F1 (or Alt+F2) to switch terminals and get to a text login. (plymouth in Ubuntu boots on VT7, the same VT used for the X display; VTs 1-6 are reserved for text console logins.)

You can also try booting without any of the 'quiet', 'splash', or 'text' options. If this allows gdm to start, then there is a bug in the interactions between plymouth and gdm affecting your system. In that case, you should file a bug report against Ubuntu in launchpad:

share|improve this answer
I think that's it, forgot to update that I tried doing that and it seemed to let me log in via text. But now I have reinstalled the system. Thanks though! – TanoPiloni Oct 14 '11 at 2:02

I would reinstall gdm and libpcre3.

If that doesn't help, please post the full logs somewhere and provide the link to it here.


share|improve this answer
Ok. Did that. Now it's stuck at bootup saying "fsck from util-linux-ng 2.17.2 /dev/sda4:clean, 306369/2899968 files, 7123600/11599365 blocks init: ureadahead-other main process (713) terminated with status 4 Starting AppArmor profiles Skipping profile in /etc/apparmor.d/disable: usr.bin.firefox [OK] Setting sensors limits [OK]. After that it doesn't say or do anything else. It has a blinking cursor, but at least it reacts if I Ctrl+Alt+Del it. I'll use a LiveUSB to get my log files and paste them up here in a bit. – TanoPiloni Sep 19 '11 at 23:29 - Syslog. - Xorg.0.log – TanoPiloni Sep 20 '11 at 2:44
I don't see any other problems than the already mentioned. Could you also post /var/log/apt/term.log and dpkg -l libpcre3? – arrange Sep 20 '11 at 18:55
Ok, I'll get those. Can I do dpkg -l libpcre3 from the Recovery Mode? Cuz Ubuntu isn't even booting up on text mode now. – TanoPiloni Sep 20 '11 at 21:05
Yes, it's the same. – arrange Sep 20 '11 at 21:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.