Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, I just bought a new laptop yesterday (Toshiba Portege R835-P70) with an Intel graphics accelerator and installed Xubuntu 11.04. Everything works fine except after waking from standby. The screen brightness controls stop working. I've tried "cat "brightness:4" > /proc/acpi/toshiba/lcd", as su, but nothing happens. It works perfectly fine after a fresh boot, but ceases to work after a wake from standby.

I looked in the syslog and kern.log and they both give this error after waking from sleep and when I try to change the brightness:

Sep 18 15:11:15 PORTEGE-R835 kernel: [ 102.456526] ACPI Error: [GTF0] Namespace lookup failure, AE_NOT_FOUND (20110112/psargs-359) Sep 18 15:11:15 PORTEGE-R835 kernel: [ 102.456531] ACPI Error: Method parse/execution failed [_SB_.PCI0.SAT0.PRT0._SDD] (Node ffff880147646cd0), AE_NOT_FOUND (20110112/psparse-536) Sep 18 15:11:15 PORTEGE-R835 kernel: [ 102.456550] ACPI Error: [GTF0] Namespace lookup failure, AE_NOT_FOUND (20110112/psargs-359) Sep 18 15:11:15 PORTEGE-R835 kernel: [ 102.456554] ACPI Error: Method parse/execution failed [_SB_.PCI0.SAT0.PRT0._GTF] (Node ffff880147646cf8), AE_NOT_FOUND (20110112/psparse-536) Sep 18 15:11:15 PORTEGE-R835 kernel: [ 102.458177] ACPI Error: [GTF0] Namespace lookup failure, AE_NOT_FOUND (20110112/psargs-359) Sep 18 15:11:15 PORTEGE-R835 kernel: [ 102.458181] ACPI Error: Method parse/execution failed [_SB_.PCI0.SAT0.PRT0._SDD] (Node ffff880147646cd0), AE_NOT_FOUND (20110112/psparse-536) Sep 18 15:11:15 PORTEGE-R835 kernel: [ 102.458193] ACPI Error: [GTF0] Namespace lookup failure, AE_NOT_FOUND (20110112/psargs-359) Sep 18 15:11:15 PORTEGE-R835 kernel: [ 102.458196] ACPI Error: Method parse/execution failed [_SB_.PCI0.SAT0.PRT0._GTF] (Node ffff880147646cf8), AE_NOT_FOUND (20110112/psparse-536) Sep 18 15:11:23 PORTEGE-R835 kernel: [ 110.661102] ACPI: Failed to switch the brightness Sep 18 15:11:23 PORTEGE-R835 kernel: [ 110.917468] ACPI: Failed to switch the brightness Sep 18 15:11:24 PORTEGE-R835 kernel: [ 111.196951] ACPI: Failed to switch the brightness

Any ideas? Is there something I can manually restart that might help?

Edit: Here's a pastebin of it. Easier to read: http://pastebin.com/jET8ZtaF

Also happening on the Toshiba Satellite R830.

share|improve this question
    
If ACPI tables change consistency during suspend/resume, something is severely broken. You might want to check Toshiba's web site for firmware updates. –  aquaherd Sep 19 '11 at 17:45
    
This question should instead be filed as a bug report, thanks! Instructions here. –  Jorge Castro Feb 4 '12 at 0:47
add comment

closed as off topic by Marco Ceppi Feb 4 '12 at 1:33

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.