Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Several symptoms:

  • No splash screen, just a console
  • No TTYs available (CTRL+ALT+F1 etc..), just random coloured bars

A while ago, I've used a tutorial to fix Plymouth bootsplash resolution and changed settings I don't quite recall now. What is the proper way to reinstall and reset Plymouth and/or GRUB settings to see if removing my modifications will fix the boot to some acceptable level?

NB: I've updated to 11.10-beta hoping it would fix the problem, but this originally happened on 11.04

Edit: I think the tutorial I followed is this one but I'm not 100% sure. Also, I think the things mentioned in the tutorial are not the only ones I've changed, since I've tried to fix this when it first happened, so I may have messed up other stuff too. This is why I'm looking for a "reset all" solution.

share|improve this question
    
Can you provide us a link to the tutorial you followed to edit the Plymouth bootsplash resolution? –  nitstorm Sep 18 '11 at 16:30
    
@nitstorm: I've updated the question ;) –  dr Hannibal Lecter Sep 18 '11 at 17:10
    
Cool :) Did you try undoing each of the steps in that tutorial? –  nitstorm Sep 18 '11 at 17:20
    
@nitstorm: Hm, I have to say I didn't.. I figured the update from 10.10 to 11.04 caused the problem so I didn't think my modifications are a problem. Now, I think I might try it... :) –  dr Hannibal Lecter Sep 18 '11 at 17:45
    
You probably made some changes to your /etc/default/grub file, so if you are at a loss, give us the contents of it. –  arrange Sep 18 '11 at 18:05
show 2 more comments

1 Answer 1

up vote 2 down vote accepted

Did you try undoing each of the steps in that tutorial?

Like, (Note: This is just an undoing of whatever that was done in that tutorial)

  1. sudo apt-get remove v86d

  2. editing the /etc/default/grub file and

    1. changing the line 9 which would now read GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap" back to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

    2. and line 18 which would now read - GRUB_GFXMODE=1280x1024 back to GRUB_GFXMODE=1280x1024.

  3. gksudo gedit /etc/initramfs-tools/modules and remove the last line reading uvesafb mode_option=1280x1024-24 mtrr=3 scroll=ywrap

  4. Remove the line that reads FRAMEBUFFER=y in the /etc/initramfs-tools/conf.d/splash file

  5. Then run sudo update-grub2

  6. Then run sudo update-initramfs -u

  7. Then reboot

share|improve this answer
    
Cheers and thanks again ;) –  dr Hannibal Lecter Sep 20 '11 at 20:38
    
Thanks to you too ;) Cheers! –  nitstorm Sep 20 '11 at 20:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.