Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Used win 7 and got resolution 1280x1024 and when i installed Ubuntu 11.04 got resolution of 1152x864(made that possible by changing from the advanced option in the nvidia xorg file)went to system settings and got 'monitor unknown'.Using a nvidia 8400GS and using 173 version of driver.

xrandr o/p:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 240, current 1152 x 864, maximum 1152 x 864
default connected 1152x864+0+0 0mm x 0mm
   1024x768       50.0     60.0  
   800x600        51.0     52.0     53.0  
   680x384        54.0     55.0  
   640x480        56.0  
   512x384        57.0  
   400x300        58.0  
   320x240        59.0  
   1152x864       60.0* 

xorg o/p:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 270.29  (buildd@roseapple)  Fri Feb 25 14:43:24 UTC 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: builtin, VertRefresh source: builtin
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-1"
    HorizSync       28.0 - 55.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400 GS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1152x864 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Planning to use docky but resolution is so low that its waste to use it.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Increasing the line HorizSync in xorg.conf like this

HorizSync       28.0 - 120.0

used to help in days of yore with 19" CRTs. (60hz * 1280 columns + some traceback equals a minimum of 78 kHz, not 55.)

share|improve this answer

Maybe you can solve the problem if you make the following changes in the file /etc/X11/xorg.conf.

Add this line to the section Monitor:

Option  "PreferredMode" "1280x1024"

Remove this line from the section Screen:

Option  "metamodes" "1152x864 +0+0"

Add the following line to the subsection Display (you can add other resolutions):

Modes   "1280x1024" "1024x768"

Then you have to restart the xserver:

sudo service gdm restart
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.