Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My installation failing log:

 sam@/home/sam/code/ros/ai/cram/roslisp_repl$ sudo apt-get update
 Get:1 http://packages.ros.org maverick Release.gpg [198B]
 Ign http://packages.ros.org/ros/ubuntu/ maverick/main Translation-en                                   
 Hit http://ppa.launchpad.net maverick Release.gpg                                          
 Ign http://ppa.launchpad.net/abogani/ppa/ubuntu/ maverick/main      Translation-en
 Hit http://ppa.launchpad.net maverick Release.gpg                    
 Hit http://archive.ubuntu.com maverick Release.gpg                   
 Ign http://archive.ubuntu.com/ubuntu/ maverick/main Translation-en   
 Ign http://archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en
 Get:2 http://packages.ros.org maverick Release [3032B]               
 Ign http://ppa.launchpad.net/cnav/ppa/ubuntu/ maverick/main Translation-en                       
 Hit http://ppa.launchpad.net maverick Release.gpg                                          
 Ign http://ppa.launchpad.net/gummi/gummi/ubuntu/ maverick/main      Translation-en              
 Hit http://ppa.launchpad.net maverick Release                                              
 Ign http://packages.ros.org maverick/main amd64 Packages                                               
 Ign http://packages.ros.org maverick/main amd64 Packages                                   
 Hit http://ppa.launchpad.net maverick Release                        
 Hit http://ppa.launchpad.net maverick Release                                                          
 Get:3 http://extras.ubuntu.com maverick Release.gpg [72B]                                              
 Ign http://extras.ubuntu.com/ubuntu/ maverick/main Translation-en                                 
 Get:4 http://packages.ros.org maverick/main amd64 Packages [121kB]                         
 Hit http://ppa.launchpad.net maverick/main Sources                                              
 Hit http://extras.ubuntu.com maverick Release                                                   
 Hit http://extras.ubuntu.com maverick/main Sources                                               
 Ign http://archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en     
 Ign http://archive.ubuntu.com/ubuntu/ maverick/universe Translation-en                             
 Hit http://extras.ubuntu.com maverick/main amd64 Packages                                          
 Hit http://archive.ubuntu.com maverick Release                                                     
 Hit http://ppa.launchpad.net maverick/main amd64 Packages                    
 Hit http://archive.ubuntu.com maverick/main Sources                          
 Hit http://ppa.launchpad.net maverick/main Sources                           
 Hit http://ppa.launchpad.net maverick/main amd64 Packages                    
 Hit http://archive.ubuntu.com maverick/restricted Sources                    
 Hit http://archive.ubuntu.com maverick/universe Sources                      
 Hit http://archive.ubuntu.com maverick/multiverse Sources                    
 Hit http://ppa.launchpad.net maverick/main Sources     
 Hit http://ppa.launchpad.net maverick/main amd64 Packages                    
 Hit http://archive.ubuntu.com maverick/main amd64 Packages                   
 Hit http://archive.ubuntu.com maverick/restricted amd64 Packages
 Hit http://archive.ubuntu.com maverick/universe amd64 Packages
 Hit http://archive.ubuntu.com maverick/multiverse amd64 Packages
 Fetched 125kB in 7s (15.7kB/s)                                                                         
 Reading package lists... Done

 sam@/home/sam/code/ros/ai/cram/roslisp_repl$ sudo apt-get install      libnss3-dev
 Reading package lists... Done
 Building dependency tree       
 Reading state information... Done
 Some packages could not be installed. This may mean that you have
 requested an impossible situation or if you are using the unstable
 distribution that some required packages have not yet been created
 or been moved out of Incoming.
 The following information may help to resolve the situation:

 The following packages have unmet dependencies:
  libnss3-dev : Depends: libnss3-1d (< 3.12.7-0ubuntu1.1~) but      3.12.9+ckbi-1.82-0ubuntu0.10.10.1 is to be installed
 E: Broken packages

 sam@/home/sam/code/ros/ai/cram/roslisp_repl$

How to install it?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

You're missing the maverick-updates and security.ubuntu.com repositories. Edit /etc/apt/sources.list and add:

deb http://archive.ubuntu.com/ubuntu/ maverick-updates main universe restricted
deb-src http://archive.ubuntu.com/ubuntu/ maverick-updates main universe restricted

deb http://security.ubuntu.com/ubuntu maverick-security main restricted
deb-src http://security.ubuntu.com/ubuntu maverick-security main restricted
deb http://security.ubuntu.com/ubuntu maverick-security universe
deb-src http://security.ubuntu.com/ubuntu maverick-security universe
deb http://security.ubuntu.com/ubuntu maverick-security multiverse
deb-src http://security.ubuntu.com/ubuntu maverick-security multiverse

Refresh your packages list and try again:

sudo apt-get update
sudo apt-get install libnss3-dev
share|improve this answer
    
I have revised my origin post. I can't install that package even I use apt-get update. –  sam Sep 18 '11 at 10:15
    
@sam: check the updated answer –  Lekensteyn Sep 18 '11 at 11:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.