Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This error occur both in Synaptic and via terminal so I can't update or install new packages:

LANG=en_US;sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of gens:i386:
 gens:i386 depends on libc6.
 gens:i386 depends on libgcc1.
 gens:i386 depends on libglib2.0-0 (>= 2.4.0).
 gens:i386 depends on libgtk2.0-0 (>= 2.4.0).
 gens:i386 depends on libpng12-0.
 gens:i386 depends on libsdl1.2debian (>= 1.1.3).
 gens:i386 depends on libstdc++6.
 gens:i386 depends on xdg-utils.
 gens:i386 depends on zlib1g.
dpkg: error processing gens:i386 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 gens:i386

I searched the package to remove it but I didn't found it. And when I try to install something from synaptic show me this:

Gtk-CRITICAL **: IA__gtk_assistant_set_page_header_image: assertion `child != NULL' failed at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 27, <> line 4.
dpkg: errore fatale non recuperabile, uscita: [fatal error not recoverable, exit]
 errore di sintassi: gruppo "cdemu" sconosciuto nel file statoverride [syntax error: "cdemu" group unknown in the file staoverride(?)]
E: Sub-process /usr/bin/dpkg returned an error code (2)

Output of dpkg -l gens

raffaele@Natty:~$ LANG=en_US;dpkg -l gens*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version        Description
+++-==============-==============-============================================
un  gens           <none>         (no description available)

Output of dpkg -l *cdemu

raffaele@Natty:~$ dpkg -l *cdemu*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Nome           Versione       Descrizione
+++-==============-==============-============================================
ii  cdemu-client   1.4.0-0ubuntu1 Command-line client to control CDEmu daemon
ii  cdemu-daemon   1.4.0-0ubuntu1 CDEmu daemon
un  cdemu-daemon-d <none>         (nessuna descrizione disponibile)
ii  gcdemu         1.4.0-0ubuntu1 GNOME application to control CDEmu daemon

Output of cat /var/lib/dpkg/statoverride

raffaele@Natty:~$ cat /var/lib/dpkg/statoverride
root mlocate 2755 /usr/bin/mlocate
mpd audio 755 /var/lib/mpd
mpd audio 755 /var/lib/mpd/playlists
mpd audio 755 /var/log/mpd
mpd audio 755 /var/run/mpd
hplip root 755 /var/run/hplip
root ssl-cert 710 /etc/ssl/private
root cdemu 2755 /usr/bin/cdemud
mpd audio 640 /etc/mpd.conf
root crontab 2755 /usr/bin/crontab
share|improve this question
    
Show the output of dpkg -l gens* –  enzotib Sep 18 '11 at 7:23
    
How did you install the gens package? Can you post a link to it? Can you also post dpkg -l *cdemu* and cat /var/lib/dpkg/statoverride? –  arrange Sep 18 '11 at 15:05
    
I've installed it some time ago - but I've never had problems with it - via an i386 deb forced package (for an amd64). I don't remember where I found it. (And I haven't the .deb anymore). –  Hadden Sep 18 '11 at 18:41
add comment

1 Answer

I've found and removed the .deb with

LANG=en,us sudo dpkg -r gens:i386

Now I've to resolve the other cdemu/gnome issue (look above).

Finally I found a solution (I hope will help someone):

In a terminal, type

sudo gedit /var/lib/dpkg/statoverride

delete the row about cdemu in the file

root cdemu 2755 /usr/bin/cdemud

Save it. Now you can update. (The problem was an ubuntu natty bug)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.