Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a D-Link DIR-655 router and a laptop with a Intel WiFi Link 5100 network card.

I'm running Ubuntu 11.4 x64 - uname -a:

Linux fraekkert 2.6.38-11-generic #48-Ubuntu SMP Fri Jul 29 19:02:55 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

I've configured the router to allow both wireless g and n, and another laptop is connecting over n, but this laptop wont.

I remember that wireless N were temporarily disabled when Natty came out, but I can't figure out if anything have happened since then, so I guess the memory leak must've been resolved by now.

This is the output from lshw:

*-network
            description: Wireless interface
            product: WiFi Link 5100
            vendor: Intel Corporation
            physical id: 0
            bus info: pci@0000:01:00.0
            logical name: wlan0
            version: 00
            serial: 00:24:d6:65:0d:d0
            width: 64 bits
            clock: 33MHz
            capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
            configuration: broadcast=yes driver=iwlagn driverversion=2.6.38-11-generic firmware=8.83.5.1 build 33692 ip=192.168.0.100 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
            resources: irq:45 memory:e3500000-e3501fff

And the output from dmesg | grep iwl:

[   20.943539] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[   20.943544] iwlagn: Copyright(c) 2003-2010 Intel Corporation
[   20.943691] iwlagn 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   20.943703] iwlagn 0000:01:00.0: setting latency timer to 64
[   20.943750] iwlagn 0000:01:00.0: Detected Intel(R) WiFi Link 5100 AGN, REV=0x54
[   20.966066] iwlagn 0000:01:00.0: device EEPROM VER=0x11f, CALIB=0x4
[   20.966071] iwlagn 0000:01:00.0: Device SKU: 0Xb
[   20.966370] iwlagn 0000:01:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
[   20.966466] iwlagn 0000:01:00.0: irq 45 for MSI/MSI-X
[   25.869658] iwlagn 0000:01:00.0: loaded firmware version 8.83.5.1 build 33692
[   25.879814] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'

Edit:

The interface is working, but only in g-mode. If I turn my access point to n-only, I can't connect to it.

The output of rfkill list:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
share|improve this question
    
please can you add the output of rfkill list. thanks. –  fossfreedom Sep 17 '11 at 15:19

2 Answers 2

I think I see MSI there somewhere--I think your laptop's probably MSI, so...

I have an MSI x400, and it has also an Intel WiFi Link 5100. The first time I installed Ubuntu 11.04-amd64 (beta 2), the wi-fi also didn't work. I think, back then, it didn't tell if the hardware enable/disable were used. Try to check if the hardware button for the wireless is involved somehow. Mine was just turned off by the hardware button.

share|improve this answer
    
Thanks, but the hardware is on and working in g-mode. I just cannot connect to the access-point with wireless n. –  LasseValentini Sep 17 '11 at 21:29

Examine the following folder /etc/modprobe.d

If there is a file in there called something like intel-5300-iwlagn-disable11n.conf or intel-5100-iwlagn-disable11n.conf then edit the file

i.e.

sudo nano [filename.conf]

edit the line that says

options iwlagn 11n_disable=1

to

options iwlagn 11n_disable=0

Save and reboot.

source

share|improve this answer
    
There's nowhere in my /etc/modprobe.d/ folder where the 11n_disable option is mentioned. I'll try to add the 11n_disable=0 line and reboot to see if anything changes. Thanks. –  LasseValentini Sep 19 '11 at 8:22
    
ok - if I understood that source link correctly - if the two named conf files (intel-5300... / intel-5100...) dont exist in the folder then create one/or the other/both and add the "options" text into the file. –  fossfreedom Sep 19 '11 at 8:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.