Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When attempting to run the ubuntu 11.04 live CD on my wife's laptop, I consistently get a black screen with multicolored vertical bars - no video.

This happens only when using kernel mode setting. When i boot with modesetting off, it boots without problems. However, I'm not really interested in using natty in fallback mode, and would like to try out the 3d accelerated version. I believe that it should be supported on my hardware (Radeon RS482 - Radeon Xpress 200M).

Is this just a bug for which there is currently no fix, or is there some workaround for it?

Update: This also happens with the latest 11.10 beta1.

share|improve this question

closed as too localized by jrg Feb 28 '12 at 13:43

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Well that happens because it doesn't support it, the AMD driver doesn't support it and if the other choice which is the RadeonHD open source driver for 3D accel. doesn't work you're out of luck. –  Uri Herrera Sep 19 '11 at 0:44
    
umm..do you know this or are you just making assumptions? As mentioned in my question, my video card should be supported –  vezult Sep 20 '11 at 2:10
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  jrg Feb 28 '12 at 13:43

1 Answer 1

I solved this today for my laptop containing the same Radeon Xpress 200M video chipset.

The trick is to force the radeon kernel driver to load early in the boot process.

Add 'radeon' to the file /etc/initramfs-tools/modules

Run update-initramfs -u afterwards to update the initrd image for your kernel.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.