Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Long story short: I was a happy user of the first generation (screen resolution: 1024x576), with a 8GB SSD. But SMART warned me about a forthcoming disk error, so I had purchased one OCZ Vertex Plus 60G SSD, and planned to do a fresh install, download Universal-USB-Installer- and 11.04 image, create my installer key.

But there goes the horror:

  1. first (normal) installation seemed to be successful. I had used the installer's formatting tool, with 15G as / 2.5 G swap, and the rest for /home. But after the reboot (the installer USB media still plugged in), the third partition was not recognized/mounted automatically. Even worse: I had tried to mount manually via mount -t ext4 /dev/sda /home but I was out of luck as it complained about bad fs type, superblock.... So I did a mkfs.ext4 /dev/sda3, but still can't mount. Even worse: after unplugging the USB installer and rebooting I was greeted with GRUB error 17.
  2. OK read a lot, reinstall, this time format with GParted (from the Ubuntu menu) using GPT partition table, this time: 2.5 G swap, the rest is /, then run the installer, and used the previously created partitions. After rebooting with the USB installer still plugged in everything seemed normal. After unplugging the USB and rebooting, I was greeted with GRUB unknown fs, with grub rescue> where I wasn't able to boot :-(
  3. (and 4....6) read and research a lot, tried Archlinux (shame on me, I love that distro too), same story either with partitioning via gfdisk, using GPT table, then tried fdisk -H 32 -S 32 /dev/sda as described here: and double checked the results as recommended: But the results are the same: I can boot with my USB plugged in (and if there are more then one partition the last is not recognized). After unplugging the USB key, I can't boot. I had also tried the recommendation to create the 1 Mb BIOS boot partition on the GPT partition (same archlinux SSD wiki page), still no luck. I had tried without the BIOS boot, and syslinux bootloader. Still no luck.

I really need that machine to work on Monday. Could somebody help me out? Thanks in advance, Zsolt

share|improve this question
You know that a partition needs to be formatted, and not the whole disk? E.g. /dev/sda1 instead of /dev/sda. I recommends against putting a swap on the SSD to enlarge the SSD's life span. It looks like the boot loader has been installed to the wrong disk. Be sure to select the SSD and not your SSD when installing the bootloader. – Lekensteyn Sep 17 '11 at 8:01
Thanks for your input, yeah, I did format sda4 not sda of course. – Zsolt Botykai Sep 17 '11 at 18:25
up vote 1 down vote accepted

I'm having the exact same trouble as you have. Tried a fresh install on 11.10 but upon first reboot im getting the grub rescue> prompt.

From what I can google - Dell mini v10 sports the Intel 945 chipset. There are apparently issues with this chipset and the Vertex plus SSD.

Most post are on Win7 issues, but this goes for all os:es - issue is with the chipset and not the os:

There are some more threads on issues with the 945 and Vertex plus, search the ocz forums.

share|improve this answer
Actually I had a SR at OCZ, but they responded like "there is no problem with the specific chipset, but we are testing it right now". Then they closed the ticket without any further info. – Zsolt Botykai Oct 23 '11 at 5:45

Sounds like the boot loader got installed on the USB key.

That happened to me once (but on an ATI desktop box). The distro including /boot was properly installed and it booted just fine when the USB key was inserted, but remove it and it'd hang indefinitely after the BIOS screen. In your case maybe you have an old/broken boot loader there, that might explain the behavior you're seeing.

Anyway, solution is:

sudo grub-install /dev/sda
sudo update-grub

I think if you make your usblive without persistence (set it to 0) it will work around this problem.

I seem to recall verifying there's a bug report filed about this in Launchpad. There's also numerous Q's posted here at askubuntu about the same problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.