Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a HP Compaq Presario F500 (an F579WM). I replaced the 1GB(2x512MB) of RAM in it with 2GB(2x1GB). Since this upgrade the computer will switch to a text screen, with what looks like a backtrace or something. It often says something about a double fault or null pointer dereference. It does this rather unpredictably, though it tends to happen when you are trying to do something (but will still happen if you leave it long enough). It often happens with Firefox/Chromium (it could be me, but sometimes it seems like scrolling tends to cause it). It looks like it lists different programs (compiz, chromium-browser, etc).

I have run memtest for 10+ hr and got no errors. If if try each stick of RAM individually, it works fine. I have tried using the Nvidia driver. I've tried using the Nouveau driver. I've tried using no 3d at all. Still happens. If I run Windows, I don't experience any crashes in Windows. (So it must be some bug/setting problem with Ubuntu).

So, how do I fix this(preferable) or get the information to report a bug?

More Details: The 2GB of memory is matching; they are the same exact item. This model of laptop has two slots and (supposedly) support 2GB of RAM. Before I upgraded the RAM, I had two sticks at 512MB each in it. I replaced those with two sticks of 1GB each (which are the same product as each other). The odd thing is that the computer works fine in Linux if I use one stick of 512MB and one of 1GB. (Windows works fine with two sticks of 1GB)

Dmidecode says the maximum RAM is 2GB, so I shouldn't be over the limit.
[Output of sudo dmidecode]

After googling, I found this: https://lkml.org/lkml/2011/3/27/17 If this is the same problem, how long will it take for the fix to be included in Ubuntu?

[Example error screen (reptyped)]
[2nd example of error] [A third and fourth example] - Retrieved by SSH and tail -f /var/log/syslog

share|improve this question
3  
Are you certain that your motherboard can handle the max of 2GB in a single stick? Not all motherboards can handle every stick of memory - if your max ram limit for your mobo is, say, 4GB, and it has 4 DIMMs, then it usually can only handle a max of 1GB per DIMM, for example. –  Thomas W. Sep 16 '11 at 18:21
    
Each stick is 1GB, for a total of 2GB. –  Azendale Sep 17 '11 at 16:33
    
Do you use Windows? Is it problematic on Windows as well? –  Oxwivi Sep 17 '11 at 19:51
    
Nope, no crashes in Windows with 2GB of RAM. –  Azendale Sep 17 '11 at 21:49
    
I may be reading that dmidecode wrong - but your RAM looks like ECC Memory (your dmidecode says there is an ECC error) - I think this is your key issue. –  fossfreedom Sep 17 '11 at 22:47

1 Answer 1

Here are your specifications for your computer.

http://www.crucial.com/store/listparts.aspx?model=Presario%20F500%20Series&cpe=PR

Sometimes not having a matched pair of memory modules can cause a problem.

share|improve this answer
    
The modules are matched. I bought two of the same 1GB stick product. Also, everything works fine with Windows and everything works fine if I put in an (unmatched) stick of 1GB and a stick of 512MB. –  Azendale Sep 17 '11 at 16:34
    
"Everything works fine with Windows" - the usage pattern in Windows is different than in Linux so the problem may not show. You should run a program like memtest86+ (check the boot menu on the Ubuntu CD) to be certain. –  Thorbjørn Ravn Andersen Apr 7 at 7:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.