Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I boot up my PC from the CD, it starts shows the Ubuntu logo with the loading sign and then gives me this error:

Can not mount /dev/loop0(/cdrom/casper/filesystem/squashfs) om //filesystem squashfs

I tried downloading and burning the ISO again but I got the same problem. I also tried using a Ubuntu 10.04 Lucid Lynx CD but it shows the same error too. It happens on 2 PCs, one with 512 MB RAM and the other with 2 GB RAM. The same CD works flawlessly on my laptop.

Error while installing Ubuntu from CD "Can not mount /dev/loop0(/cdrom/casper/filesystem/squashfs) om //filesystem squashfs"

share|improve this question
add comment

6 Answers

up vote 2 down vote accepted

Your computer may not have enough RAM to use the Desktop CD. Try installing with the Alternate CD and see if you have any better success.

See also: https://help.ubuntu.com/community/Installation/SystemRequirements

Also you might want to double check the CD image has downloaded properly:

share|improve this answer
add comment

I had the same error when my .iso file was missing some bits. Redownloading and mounting it again solved it for me.

share|improve this answer
    
I used the same iso for two computers. It worked flawlessly on one but gave this error on the other. –  User Oct 20 '10 at 22:31
add comment

Guys it seems that this issue has more to do with what kind of drive your packing than not enough free space, i have found that an easy way to solve this problem is to download the ubuntu 10.10(it does not have to be this verison, this just happens to be the latest one) dvd version. These "DVD Versions" tend to be 4GB in size as appose to the regular 690-700mb ISO File. Please tell me if this has also solved your problem.

share|improve this answer
add comment

I had this error when installing 10.10 64 bit from CD-R. I then burned the same iso image to dvd-r and also changed bios plug-and-play option from off to on - error is gone.

share|improve this answer
add comment

Try installing from the host system instead of from a CD or DVD - VMware 8 gives you the option of installing the guest operating system from an iso located somewhere on the host operating system. I'm running vmware on Windows 7 and located the ubuntu 10.4 iso in the MyDocuments folder on Windows. Ubuntu installed under VMWare with no problems.

share|improve this answer
add comment

Burning to a DVD instead of a CD solved this. The CD was supposed to be big enough if you look at the sizes, but it never worked for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.