Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Ubuntu Natty, urxvt (with 256 colours), and Imagemagick (display -window root [...]) to set the root window to a picture. When I use the transparancy (-tr) option on urxvt, I get the Ubuntu X login screen background (The pink/purple one) and not the image that is currently on the root window. See picture at the bottom.

Note that the same problem exists if I run gnome-terminal and set its transparency.

I suspect that imagemagick is not drawing on the right X11 layer but I (and google) cannot figure out what the right option is.

Could the problem be with either the xorg configuration or with window composition?

enter image description here

Cross post from here and here in the vain hope that someone will know the answer here. If that offends, feel free to close. And it seems that it was indeed a vain hope...

share|improve this question

2 Answers 2

fake transparency {i.e. cropping the root image} is turned on with: +tr {and e.g.: -sh 20} -tr turns off fake transparency this is probably what youre doing, and probably not what you want to do

real transparency {i.e.: with a compositor} is done simply by setting the alpha of the window e.g.: xcompmgr or compiz or whatevs urxvt -bg rgba:2000/2000/2000/dddd

see if xcompmgr and transset can do it for you; if not, nothing will likely work until you get that working

share|improve this answer
up vote 0 down vote accepted

I ended up re-sizing the images using convert into another directory and then using feh to display them. Ugly but works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.