Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How to select by keyboard?

After selecting , I click Menu's Edit, it shows 'Copy '.

How to type copy by keyboard?

Thank you~

share|improve this question
add comment

3 Answers

up vote -1 down vote accepted

Try turning on PC Selection mode. See also the copy/paste page on emacswiki

share|improve this answer
    
Is PcSelectionMode also support for normal emacs or should I install another emacs? By the way,I know C- means ctrl, M- means alt, and what's S- ? –  sam Sep 17 '11 at 5:41
    
It should be available in the default installation of GNU Emacs. You can try turning it on with M-x pc-selection-mode –  Tom Sep 17 '11 at 6:22
    
Thank you~ I have loaded pc-selection-mode. How to press S- ? –  sam Sep 17 '11 at 9:27
    
@sam: I suppose S is the Shift modifier –  enzotib Sep 17 '11 at 9:34
add comment

Press Ctrl-Space to mark start of block.

Move cursor until end of block.

Press Alt-w to copy

Move to insert position

Press Ctrl-y to paste

share|improve this answer
    
I can't select by ctrl+space,and if I use mouse to select,I also can't copy by alt+w. What happened? –  sam Sep 16 '11 at 14:52
    
@sam: Ctrl-space do not select, only mark the start of block. Then you will see the selection expanding if you move the cursor. –  enzotib Sep 16 '11 at 15:11
    
Sorry for my typo unclearly,I know I should use keyboard to move cursor. When I press Ctrl+space it just open input method like scim. Even when I use mouse to select,I also can't copy by alt+w. Because when I open gedit to paste,it appears nothing. –  sam Sep 17 '11 at 5:41
    
I mean to copy and paste inside emacs itself, don't know if it work to paste outside of it. And you can try Ctrl-@ instead of Ctrl-space. –  enzotib Sep 17 '11 at 7:41
    
I have tried ctrl+2 and ctrl+shift+2 (means ctrl+@) with keyboard's direction key(up,down,left,right on the right of keyboard), but I also can't select any characters. –  sam Sep 17 '11 at 9:30
add comment

I found another way just the same as windows' operations.

Emacs menu > Options > C-x/C-c/C-v Cut and Paste (CUA).

That option will let me use Shift+Arrow keys to select, Ctrl+C to copy, and ctrl+V to paste.

But it only work in emacs. It could not paste on gedit.

If I want to paste to gedit, I should use menu > edit > copy.

I didn't find any shortcut to menu > edit > copy.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.