Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Right after boot up, I can record using the line input just fine, but after some time (I haven't been able to tell how much), it stops working.

All it records is silence with a bit of static.

I don't think the program is the culprit since I've tried arecord and Audacity.

What could be the reason? And how could I debug this?

share|improve this question
    
Sorry, no answer here but your question would be easier to read as "Recording from line-in" (hyphen optional), took me a couple seconds to not read "online in". –  Rob Van Dam Oct 11 '10 at 22:04
    
This is a bug. Please file one using ubuntu-bug alsa-base, thanks! –  Daniel T Chen Dec 4 '10 at 23:43
add comment

2 Answers

Given that you've tried two different recording applications, I'd be concerned about a hardware defect. Another possibility is that a third application starts up at some point and intentionally mutes the line-in channel.

In a terminal, you can use alsamixer to show volume levels for all playback and capture channels. Be sure to press F5 in order to display all available channels. Sometimes all the channels won't fit on one screen, so also be sure to keep scrolling to the right in order to go through the entire channel list.

share|improve this answer
add comment

When using my mic, I sometimes noticed my mic fell out when going too loud. Open the volume applet and go the the "input" tab. See if the volume bars don't touch the end, if they do, reduce the volume.

Maybe this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.