Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On Ubuntu 10.10 I would like to change my default pdf viewer to acroread.

I do not have sudo privilidges, so I want to make this change for my own user only. Acroread is already installed.

share|improve this question
2  
Does Right Click(pdf)->properties->Open With->Acroread->Choose default work? –  Capt.Nemo Sep 16 '11 at 6:24
    
@Capt.Nemo Yeah it does. Could you add this as an answer? –  Peter Smit Sep 16 '11 at 6:41
    

3 Answers 3

up vote 10 down vote accepted

To set the file associations :

  1. Right Click on the file
  2. Choose Properties
  3. Go to the Open With tab.
  4. Choose your file viewer. For eg. acroread.
  5. That's it. Click on close.

alt text

Also see this answer for an alternative method.

share|improve this answer

To set the default program to pdf

  1. gedit ~/.local/share/applications/defaults.list
  2. Add application/pdf=acroread.desktop

This will set the pdf default program as adobe reader

share|improve this answer

An update for Ubuntu 13.04. I am, however, using Gnome fallback session with no effects.

I wanted to use Foxit Reader 1.1 for my default PDF viewer, but I couldn't add it through right-click in file manager and "Open With," right-click properties and "Open With," or through "System Setting" -> "Details" -> "Default Applications."

What did work for me was "Ubuntu Tweak."

The PDF default is under the "Admins" tab, then click the "Applications Centre" then look for "All" in the "Category" column on the far left. Scroll down to find the "PDF" file type and the "Associated Application." Double-click to change (brings up a window) where you can "Add" an application through one provided or find your own.

share|improve this answer
    
This worked for Adobe Acrobat Reader, under Ubuntu 13.10. –  david6 Nov 2 '13 at 6:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.