Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded ubuntu-11.04-desktop-amd64.iso and used Universal-USB-Installer- to format my USB stick und put the ISO on it. When I tried to install from it, I've got a kernel panic just like here, except for the version number (mine was 2.6.38-8-generic #42-ubuntu). My ISO image seems to work, as I installed it into a VMWare player without problems. Booting Linux from USB works surely too, as I did it some time ago with an older Ubuntu version.

I can imagine things to try out, e.g., write the image again, try another version, pray, look for patches, etc. However, I'm looking for a time-efficient solution, something what most probably works. An advice of the sort "wait two weeks until it's surely fixed, then download again" is acceptable, I'm determined to switch to Linux, but it can wait a bit.

share|improve this question
I had troubles when I put a the USB stick in USB 3.0 ports (even if the stick is USB 3.0) but when I stuck it in USB 2.0 ports instead I had no problem. You could try that to exclude a similar problem. Also I'd try recreating the live USB. – N.N. Sep 21 '11 at 11:00
If you want to change to linux (and have a CD drive) then have a go at installing from CD. If you get the same kernel panic then update your answer to say so. – ed. Sep 21 '11 at 18:42
up vote 2 down vote accepted

Regarding the USB Installer issue. What is the overall capacity of the USB stick that you're trying to use? I ask this because I've been fiddling with this issue for the past three or four hours trying different things. And finally I think I've come up with something.

Then I started thinking about the File Systems and how it's logic works when determining the difference between a USB Flash Drive and a USB Hard drive. So with my 5gb USB Stick everything worked out cherry. Then going through the same exact steps and attempting it on my 16gb USB stick I would get the "Panic!".

Even though when mounting a USB device, whether or not it's a flash drive or a external hard drive, is referenced by the user the same way the way the File System manages the amount of space has to be different (especially when your trying to use Fat32). Try mounting it on a smaller partition something ~5gbs or so. I tested this on 5 different larger USB sticks and 5 different smaller (under 8gb) USB sticks and the results stuck all the way through.

Let me know if you end up testing this out. Because I had this problem for a while with multiple different distro's (Google the kernel panic with any distribution, Gentoo, Ubuntu, Fubuntu, Mandriva, Puppy.. Pepperment... you get the idea). So I've, in my own mind at least, ruled out it possibly being the developers.


Wanted to confirm all the USB devices that I used to attempt a FROM USB (five total) that I used them with that, after creating a smaller (4gbs is what I decided to go with) partition for the installer to be placed on all the devices that failed now work without an issue.

Softwares tested: Lili Live USB Creator, Pen Drive Linux, Unetbootin, & dd linux consol tool.


Federico Cinelli
CINELLI Motorsports LLC
Stay true.

share|improve this answer
I don't get why anybody needs to know if it's an USB stick or an USB HDD. However, I think you're right; my stick was 8 GB. In the meantime I gave it up and installed from a CD. – maaartinus Mar 28 '12 at 3:51

I have not successfully used a usb installer yet, but there is another way: install directly to the usb drive. I can't tell you exactly what you need to do (since I can't look at a live cd for reference right now), but basically you boot into a live cd, then use your usb as the "hard drive." This is an option somewhere in the advanced intsall options, but you won't see a thing that says usb. It will just show the name of your flash drive.

I'd unplug your main hard drive before you do this, in case you make a mistake.

I hope this helps!

share|improve this answer

Doing a full install to USB, (as above), will not give you the Ubiquity installer needed to install from the USB, unless you install Ubiquity CD Installer from the Ubuntu Software Center.

If Universal installer doesn't work for you, try Startup Disk Creator from the Live CD or extract usb-creator.exe from the Ubuntu iso* or try Unetbootin. I have heard of many people having problems with Universal.

*7zip is a good tool for opening iso files.

share|improve this answer
+1 > good answer – Ringtail Feb 24 '12 at 3:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.