I have my PHP Version pinned at 5.2.x, Here is the command line output
php -version PHP 5.2.10-2ubuntu6 with Suhosin-Patch 0.9.7 (cli) (built: Oct 23 2009 16:30:10) Copyright (c) 1997-2009 The PHP Group Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
Running this command to install php5-mhash :
sudo apt-get install php5-mhash
Here is the error message
Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: php5-mhash: Depends: php5-common (= 5.2.10.dfsg.1-2ubuntu6.10) but 5.2.10.dfsg.1-2ubuntu6 is to be installed E: Broken packages
My question is how do I fix this? Can I install an older version of php5-mhash and if so, how do I do that?
I am open to any suggestions.
Here is the output from running:
sudo apt-get install -f:
Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.