Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am relatively new to Ubuntu. I saw my friend's PC running Ubuntu and tried it out of curiosity.

I started with 10.10 on my old PC with an nVidia 7300GS graphics card. It would occasionally freeze but other than that it was all good. (I was using the proprietary drivers)

But a month back I bought a new one (AMD X4 955BE/ 8 GB/ Radeon HD4250) and dual booted Win 7/ Ubuntu 11.04.

The issue is that the video performance is absolutely horrible. Even standard definition videos are unwatchably choppy. This is huge deal breaker for me, since I use my PC mostly for watching movies. I downloaded the proprietary drivers but it seemed like they dragged down the performance even more.

I also installed 11.04 on my friends laptop ( A dual core with Intel HD graphics and 2GB RAM), and it works like a dream. My friend says that she hasn't had to login to Windows 7 once in the last three weeks. 1080p videos play just fine without the need for any proprietary drivers.

I would like to know if there is anything else that I can try, because I really like Ubuntu and would like to have to login to windows only when I absolutely have to.

PS: I am using the Ubuntu 11.04/X64 whereas the one on my friend's laptop is the 32 bit version.

share|improve this question
3  
Make sure you uncheck "Sync to VBlank" in the "OpenGL" plugin in CompizConfig-Settings-Manager. –  Naftuli Tzvi Kay Dec 30 '11 at 22:29
1  
as TK Kocheran said, this makes a huge difference to me –  duffydack Dec 30 '11 at 22:48

4 Answers 4

In many cases using the proprietary ATI provides better performance, if your graphics card is supported you should be able to select it from the "Additional Drivers" application.

share|improve this answer

I've been using ubuntu as my main OS for some years with AMD Radeon, what I can tell you is that the open source drivers work pretty well but I still prefere the Propietary ones.

For installing the propietary drivers you have to make sure to uninstall and completely remove the open source ones (from system configurarion -> aditional drivers, uncheck them if active and then restart)

Download the propietary driver from here http://support.amd.com/us/gpudownload/Pages/index.aspx

And just open the terminal and type

Sudo sh 

Drag the downloaded (*.run) file and press enter (dragging a file to the terminal makes it easier to get the path of the file instead of type it manually)

The idea is to get something like this

Sudo sh 'path/to/your/file.run'

When the installatuion is complete type

Sudo aticonfig --initial -f

If later on you want to uninstall type this

Sudo sh aticonfig --uninstall

Restart and your are good to go, also you can install Ccsm or Compiz config settings manager from the Ubuntu Software Center to make what TK Kocheran says, that makes a huge difference

share|improve this answer

Here is what I tried:

To fix the lack of audio with HDMI - Fast video playback with no sound

Just in case anyone else still has some video glitching after exhausting all other options. This fixed the problem for me.

Hardware: ATI Radeon HD 4250 OS: Ubuntu 12.04(32bit)

From VideoLAN Forum:

Re: Playback Slow/Choppy in Ubuntu 9.04?

by OttifantSir » Tue Aug 18, 2009 9:09 am

I just found this out myself. A "revelation" you might say. I use a Radeon 3450 HD myself, streaming video over Gigabit LAN on a 2.4GHz 2GB RAM media-PC. I suddenly realised, out of the blue, that VLC is set to default video output, meaning X11/XVideo, but the card is capable of using OpenGL. So, I changed the output to OpenGL, saved the Preferences, restarted just to be sure that was the output used. Besides bad coding, skipped frames in the original recording, not the machine skipping frames, the video output has been stable, fluid and without artifacts. Just a tip to try if you have the possibility.

share|improve this answer

http://www.thefanclub.co.za/comment/reply/118

The best way to install AMD catalyst latest or beta minus all the hard work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.