Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've converted some images from jpeg to google's WebP image format, which reduces my images' size by about 90%!

The big problem is that WebP images can only be viewed with a web browser, not with nautilus (the thumbnails) and/or any photo program at all. It seems that at this moment there is only a codec for Windows.

Does anyone know if this is also possible in Ubuntu?

share|improve this question
    
Update: I've posted a bug report here: bugzilla.gnome.org/show_bug.cgi?id=659291 –  Kapé Sep 23 '11 at 14:53
    
Is this old ? Actually the last version is 0.2 for cwebp in WebP Project. –  glococo Sep 1 '12 at 15:09
    
for nautilus, check this answer, there is also this script –  Aquarius Power Jun 8 at 23:27

1 Answer 1

up vote 5 down vote accepted

There is a plugin for the GIMP, written by Nathan Osman.

You can add this plugin from his webptools PPA:

sudo apt-add-repository ppa:george-edison55/webp

Then install the required package: gimp-webp Install gimp-webp (Click the link above or run the following):

sudo apt-get install gimp-webp

As for thumbnails in nautilus, this seems to be a bug with MIME, as apparently (so I was told) Nautilus already "supports" the webp format, but the thumbnails do not show up as they should.

share|improve this answer
    
Thanks for the info, I did not know that there was a ppa for that. I installed it and there are indeed no thumbnails in Nautilus. As for the thumbnails: that's the most annoying part. I hope this will be solved soon so I can use WebP properly. Now it's still hard to use if you have to open image by image in the web browser... –  Kapé Sep 17 '11 at 13:37
    
there seems to have no package for 14.04? any idea if an older may work? –  Aquarius Power Aug 11 '14 at 21:10
    
I tried this method to try to create the thumbnail manually but nautilus ignored the the thumbnail I created for the '.webp', could you give it a try? a bit help on it: dwebp filename.webp -o "$HOME/.cache/thumbnails/normal/md5summedResult.png" -scale 100 100 –  Aquarius Power Aug 11 '14 at 22:06
1  
@AquariusPower packages have now been updated for 14.04. –  Nathan Osman Jun 7 at 6:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.