Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My resolution is stuck at 1024x768. I've read through whatever is available here, ubuntuforums, and the ubuntu wiki. But I can't seem to fix the issue.

I've reinstalled Ubuntu, keeping only my home, var, and opt folders (mounted on other partitions).

I've tried to create a new user (so home folder is different), but still the problem continues. During the reinstallation, the resolution was at the correct value, so I know its not an issue with my monitor. There is no xorg.conf anywhere, and I'm pretty sure its not an X issue, as I tried booting into safe mode once, and it switched halfway through the boot to the lower resolution.

The plymouth boot screen is also the text one.

xrandr output

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
 1024x768        0.0*

lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

I thought that since the problem persisted after a reinstall, it should be somewhere due to my home folder, and read that the culprit might be a monitors.xml file, probably inside ~/.gnome2/, but there was no such file.

Right now, my monitor only supports 1024x768, shows the monitor as unknown in Displays, and defaults to Ubuntu-2d.

I'm using Dell Inspiron 1545 (Intel GM45, not ATI/nVidia). I've been through my history, and the only related thing I could find was installing xmonad, and uninstalling it later. Also it refuses to identify an external monitor once I connect it.

Here is my Xorg.0.log file. The output of sudo lshw -C display is as follows :

  *-display:0 UNCLAIMED   
       description: VGA compatible controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:f6c00000-f6ffffff memory:e0000000-efffffff ioport:efe8(size=8)
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:f6b00000-f6bfffff
share|improve this question
add comment

3 Answers

Do the following:

sudo apt-get install read-edid

sudo get-edid | parse-edid

It should fix the problem. I had it once with my TV. EDID is the Extended Display Identification Data and describes what features your display has.

share|improve this answer
    
It does give me the correct resolutions, but the monitor configuration settings are still stuck at "Unknown". Output : paste.ubuntu.com/689460 –  Capt.Nemo Sep 14 '11 at 19:22
    
I will think about it and tell you the solution. –  Sebastian Grebe Sep 15 '11 at 4:31
add comment

My Asus XF52 laptop with Intel video controller also had the problem of Unknown Monitor with resolution fixed at 1024 x 768. The simple fix was to install the Resolution Switcher component.

In detail: use Ubuntu Software Center to search for and install Resolution Switcher component (no need to add to Launcher). Shutdown, start, and login. Use action icon at right of top menu bar to open System Settings & select Displays icon. Monitor type is now Laptop and multiple and appropriate Resolution settings are available.

share|improve this answer
add comment
up vote 0 down vote accepted

Unfortunately I could not find the solution to this problem, but it fixed itself after a week of updates (I did not use Ubuntu for around 4-5 days, hence the delay).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.