Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Up until about a week ago I could connect to my wireless, but now I suddenly can't. Every other wireless in the area show up in the network manager. My kindle can connect to it, my friend can connect to it (in windows) without having connected to it before. My other netbook (Samsung NC10) can connect to it, but my other Samsung N150 now cannot even see it.

  • I have tried deleting the old auto entry for it in the network manager
  • Tried disabling and enabling both the networking and the wireless through the network indicator.
  • Disabled the networking through the hardware shortkut key thing [fn] + [F9]
  • Attempting to connect to it as if it was a hidden network.

I'm at a loss, how would I go about debugging and unborking my computer?

share|improve this question

4 Answers 4

up vote 5 down vote accepted

I had a similar problems a few weeks ago in a friends house. The problem was that the router was using channel 13 and by default the drivers didn't allow this. I make him change the channel and it started working again. But i think there is a way to allow this channels in the driver.

share|improve this answer
    
Ah! iwlist channel tells me that the computer only does 1-11 and my other netbook tells me it's on channel 13. Finally makes sense. Thank you. –  Kit Sunde Sep 14 '11 at 19:08
    
I spend a while googling before finding why only one network didn't showed up. –  Nachito Sep 14 '11 at 19:25

I had this problem on Ubuntu 12.04, list of networks but my home network is not on it.

Click Network ManagerEdit ConnectionsWirelessDelete the 'home network'Close and reboot.

Then go back to Network ManagerEdit ConnectionsCreate New Wireless NetworkEnter InfoSave. Reboot. All is fine now.

share|improve this answer

If the network isn't showing up, you still can connect to it by

  1. Clicking at the network icon and
  2. Choosing "Connect to Hidden Wireless Network" > "New"
  3. Then put the name and password.
    (This works even if it isn't a hidden network)

enter image description here

enter image description here

share|improve this answer
    
That sadly doesn't work for me. The network is very much being broadcast too as other devices are picking it up. –  Kit Sunde Sep 14 '11 at 18:41

I've been trying to solve this problem on and off for AN ENTIRE YEAR (OK, we have a small baby/toddler, and as of two weeks ago, another one, so I haven't been able to give it my full attention - but even so!)

And here's the solution! Log into the Router. Change the Channel from 13 to Channel 5, and hey presto! It works. All the messing around with WPA Supplicant, drivers etc. was irrelevant.

Don't need to do anything on your computer. Just change router settings.

Damm I feel stupid now.

(To be very clear, the problem I was having wasn't that WiFi didn't work - It was that WiFi clearly DID work, but I couldn't see MY router, just every other router in the building)

share|improve this answer
    
The general suggestion in this answer is to cycle through the channels available on the router. There are situations that may cause it to change the channel it broadcasts on which in turn might cause connection issues for lan machines. –  Anthony Nov 1 '12 at 23:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.