Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Sony Vaio CW23FX and use a wireless usb mouse and it worked perfect until the 2 days ago. Now the mouse is a little crazy.

When I use Chromium it works fine, but with I try to click ther unity bar or other application or alt+tab or superbutton dont work (ctrl+alt+right or left works). If I power off the mouse and use the touchpad, back to works fine, if I back for the usb mouse for a little time works fine and then bug again.

It's like the mouse freezes in the window I'm using.

I've read this Mouse randomly clicks, jumps and blocks clicking, keyboard then also messes up and tried the xwininfo -all, and returns Can't grab the mouse.

What can I do?

share|improve this question
Was that an xorg update? Have you tried rebooting? – nickguletskii Sep 14 '11 at 17:27
I guess can be a xorg update.... I already tried to reboot – Scoup Sep 14 '11 at 19:02
Try reinstalling xserver-xorg-input-all using Synaptic. – nickguletskii Sep 14 '11 at 19:05
Worked!!! Thanks!! now the xwininfo -all is printing right! – Scoup Sep 14 '11 at 19:14
No problem, this is the most common solution to problems related to updates! – nickguletskii Sep 14 '11 at 19:20
up vote 1 down vote accepted

Try reinstalling xserver-xorg-input-all using Synaptic.

Copied from comments because some people (like me) never look at the comments if there is no answer when they are having the same problem...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.