Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My graphic card is a NVIDIA GEFORCE GTX 470, under the previous ubuntu version the driver was showed as installed but not activated, so I dont had unity 3-D. I updated to Oneiric Beta. The new updated driver is showed as installed AND activated, but my account (I had only a single account in the system) only could log in unity 2D, trying to log in ubuntu (3-D) mode only showed nautilus, not any other application, or the launcher.

If I log in guest mode or if I make a new brand account, unity 3-D works, so obviously something in my main account home folder is messing with unity and my video settings.

Can anyone point me where to look ?

I dont think that this is a question specific to Oneiric, because as I say, all seems to work with a newly created account.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Run unity --reset on the main account (from a terminal). You just need to log in to the recovery console to do it.

share|improve this answer
    
sorry, just weird I cant use a new line here. Anyway running unity --replace ended with a compiz error message ("Fatal: couldnt open display :0") but pointed me in the right direction. I erased compiz sessions folder in ~home, ran compiz-settings and noticed that unity plugin was disabled (no idea why or when); enabling it and solving all the conflicts with keyboard shortcuts as were purposed did the trick. SOLVED and THANKS ! –  Ign Sep 14 '11 at 17:00
    
@Ign: you can mark the question as solved by clicking the tick (and btw I said unity --reset, as unity --replace does nothing special, it just runs unity). –  RolandiXor Sep 14 '11 at 18:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.