Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Oneiric 64-bit, and since I've upgraded I notice Synaptic has split the repositories into 64-bit and 32-bit, but it's downloading archive lists for both of them, taking twice the time as before. Can anyone explain why this is and whether I can stop it?

share|improve this question

2 Answers 2

up vote 6 down vote accepted

oneiric now has support for multi-architecture packages. So, even though you are using a 64-bit system, you can now install 32-bit packages on it. Earlier, this was not possible. Currently, this support is also available in Debian Wheezy, which will be released sometime in 2012-2013.

I do not remember the exact name this multi-architecture support over the top of my head, but when I do, I'll update this post.

Also, I don't remember seeing any mention of how to disable this feature.

share|improve this answer

It's not specific to synaptic either. I see duplicated packages in the list with aptitude (lol I just tried to tab-autocomplete that!) but not with [the new] muon in Kubuntu 11.10 (oneiric) which appears to hide this. I assume they're all using apt behind the scenes or some library that is compiling the package list.

My upgrade didn't go well, this caused me problems; it seems that aptitude is not set up to handle this.

I was able to fix it like this :

  1. sudo nano /etc/dpkg/dpkg.cfg.d/multiarch

  2. Using a # to comment out the only line making it read #foreign-architecture i386 .

Now aptitude only sees the native architecture packages.

Again this is not a specific answer but it fixes the problem you present IMO.

[go easy on me it's my first post here]

share|improve this answer
    
Hi and Welcome to AskUbuntu - this is a question and answer site. This is perhaps a comment rather than an answer to the question. –  fossfreedom Oct 19 '11 at 19:50
    
I'd say it's a partial answer towards the question "whether I can stop it". Thanks for the feedback. –  pbhj Oct 20 '11 at 1:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.