Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My University is using a WPA2 Enterprise network, it has these properties:

Authentication: PEAP (Version 0)
Inner Authentication: MSCHAPv2

Connecting to the wifi is almost impossible all the time. But sometimes it does connect. But only stays connected for 20-30 minutes, and then disconnects.

I'll post the output of nm-tool too, just in case. (While connected to the Home network, it gives no trouble).

When searching the forums, it seemed that this was a common issue, but through hours of searching I couldn't find a solution. If anyone knows of any fix, please let me know.

  • Output of nm-tool follows.

    - Device: wlan0  [Home] --------------------------------------------
    Type:              802.11 WiFi
    Driver:            iwlagn
    State:             connected
    Default:           yes
    HW Address:        AC:72:89:3A:71:95
    
    Capabilities:
      Speed:           54 Mb/s
    
    Wireless Properties
      WEP Encryption:  yes
      WPA Encryption:  yes
      WPA2 Encryption: yes
    
  • Output of: uname -a

Linux vostro 2.6.38-11-generic #48-Ubuntu SMP Fri Jul 29 19:02:55 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

share|improve this question

closed as too localized by Bruno Pereira Apr 2 '12 at 15:49

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
have you tried any alternative such as wicd or connman ? –  sagarchalise Sep 14 '11 at 4:58
    
@yasith - are you sure its an encryption issue - could be an MTU issue as per my answer here? askubuntu.com/questions/59335/… –  fossfreedom Sep 14 '11 at 12:54
    
@sagarchalise I tried wicd today, didn't seem to work out. It's interesting to note that it always connects when I turn the computer on, when I'm in the wifi zone. –  yasith Sep 15 '11 at 3:10
    
@fossfreedom Thank you for the link. I will try that tomorrow at uni. It's hard to debug the issue, because at uni, I don't have wifi, and at home, I don't have the buggy connection. It would be great if anyone of you can direct me towards how to debug this issue. –  yasith Sep 15 '11 at 3:13
    
I looked into the MTU, and it's already at the auto setting. Here's the output of dmesg pastebin.com/cAUcbzxU –  yasith Sep 15 '11 at 12:19
show 8 more comments

Browse other questions tagged or ask your own question.