Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've set up both mediatomb and minidlna on my ubuntu 10.04 PC. They both stream media perfectly to my Android phone (Samsung Galaxy) and Google TV (Logitech Revue) using UPNP. Yet my laptop (Ubuntu 11.04), does not see my PC's services on the network.


Forgot to mention that, on my laptop, I've tried both boxee and totem, with the Coherence plugins, with no results.

share|improve this question
I'm running the xbmc client on my Natty laptop against mediatomb on my lucid server. That combinations works fine for me. – fossfreedom Sep 14 '11 at 11:23

What software are you using as a client? Or are you looking for a software recommendation?

If you are after a software recommendation, Ubuntu's default movie player (Totem) can act as a DLNA player if you install the totem-plugins-extra package. Once the package is installed, start the movie player and pick Plugins... from the Edit menu. Check the checkbox next to Coherence DLNA/UPnP Client and you should be good to go.

Open the movie player's side bar and select Coherence in the drop down menu. You should now be able to browse the DLNA servers on the local network and start playing movies or songs by double clicking on them.

share|improve this answer
Forgot to mention that, on my laptop, I've tried both boxee and totem, with the Coherence plugins, with no results. – lamcro Sep 14 '11 at 9:55
Okay. In that case, could you try installing the gupnp-tools package and see if your media servers show up when you run gupnp-universal-cp? This is a low level tool that shows all the UPnP devices on the network (not just media servers). Does it show anything? – James Henstridge Sep 14 '11 at 16:05
Sweet! I'll try this soon. Thanks! – lamcro Sep 15 '11 at 15:31
I just tried it and nothing shows, yet my Android phone and my Google TV see it fine. – lamcro Sep 16 '11 at 3:27
Unfortunately, I don't have another machine available to test with right now. – lamcro Sep 16 '11 at 3:28

UPnP plugin no longer available in Totem 3.0.1. Looks like package maintainer has removed:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.