Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After the installation of electricsheep, the screensaver won't work: it starts fading to black then, when it should display the screensaver, it suddenly goes back to desktop. I read that disabling compiz should fix this behaviour but I don't want to go 2d-unity. I'm using Natty. Any suggestion?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I found a whole lot of posts talking about this kind of problem: it doesn't seems to be related to electrisheep but to gnome-screensaver itself.

I tried with some stock screensavers experiencing the same behaviour: I then installed XScreenSaver and it works like a charm (googling for how to use electricsheep with XScreenSaver it wasn't that hard...)

How-to:

  1. open a terminal and sudo aptitude install xscreensaver electricsheep
  2. open "startup applications", click "add" and put as a command xscreensaver -nosplash
  3. open ~/.xscreensaver (gedit ~/.xscreensaver): at the bottom of the screensaver's list you'll have to add GL: electricsheep --root 1 \n\ , otherwise you'll not be able to see it in xscreensaver
  4. in a terminal or via ALT+F2 write xscreensaver-demo to set it up: you can also manage your power saving settings
  5. log out and log back in (or reboot)
share|improve this answer
    
Can you include the basic instructions for your solution in your answer? –  jrg Sep 19 '11 at 13:30
    
@jrg: added instructions: thanks for the advice! –  dag729 Sep 19 '11 at 17:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.