Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question has already been asked and answered for GTK-2.0 here ( Disable resize gripper in windows? ) but I couldn't find a way to achieve this on GTK-3.0 (on Oneiric Ocelot).

I've seen the answer on the above link where it is needed to recompile GTK ... I seriously hope that's not the case with GTK-3.0 and that there's a workaround like with gtk-2.0.

Now, before someone comes and asks why I would want to remove this resize grip , here's why :

  • I haven't used a resize grip or border in years, I use Alt+Click. I literally freak out when I have to use OS X or Windows.
  • Sometime it shows up when it shouldn't. Splash screen, widgets, etc ...
  • I don't find it visually appealing.

If this is hardcoded into gtk-3.0 then there should be an option in gconf or dconf to disable it.

I've fetched the source for gtk-3.0 and this seems to be related to the 063_resize_grip_default.patch where a configuration key is mentioned : "resize-grip-default".

When I grep for this in the themes I get this :

/usr/share/themes $ grep -ri resize-grip-default *
Ambiance/gtk-3.0/gtk-widgets.css:    -GtkWindow-resize-grip-default: false;
Radiance/gtk-3.0/gtk-widgets.css:    -GtkWindow-resize-grip-default: false;

If this configuration value is set to false, where does the resize grip come from ?

share|improve this question
    
Editing the question title. As Roland Taylor has noticed, the gtk+2.0 method still works, the question is only about gtk+3.0 then. –  Mathieu Comandon Sep 13 '11 at 21:21
    
I just can't remember what I used to disable it in GTK+ 3.x :S –  RolandiXor Sep 14 '11 at 16:05
    
Just a quick followup: The configuration tweak at ~/.config/gtk-3.0/gtk.css doesn't seem to have any effect in Ubuntu 12.10. I still get resize grips for all my gnome-terminal windows, even with the extra css rules for all widgets. –  Giorgos Keramidas Dec 14 '12 at 19:53

1 Answer 1

up vote 3 down vote accepted

I could disable the resize grips by putting into ~/.config/gtk-3.0/gtk.css the following code:

* {
    -GtkWindow-resize-grip-default: false;
}

or similarly to .gtkrc-2.0

* {
    -GtkWindow-resize-grip-height: 0;
    -GtkWindow-resize-grip-width: 0;
}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.