Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

To be able to boot Ubuntu 10.10 or 11.10 in my new Lenovo L5210 with Intel Sandy Bridge I need to set grub setting GRUB_GFXPAYLOAD_LINUX=text (or I will get a blank black screen with only a cursor in a up left corner?

By setting GRUB_GFXPAYLOAD_LINUX=text I get a message error: no video mode activated. instead of the cursor in up left corner.

So what does GRUB_GFXPAYLOAD_LINUX=text do exactly and what am I loosing by setting it?

share|improve this question

1 Answer 1

13.1.9 gfxpayload

If this variable is set, it controls the video mode in which the Linux kernel starts up, replacing the ‘vga=’ boot option (see linux). It may be set to ‘text’ to force the Linux kernel to boot in normal text mode, ‘keep’ to preserve the graphics mode set using ‘gfxmode’, or any of the permitted values for ‘gfxmode’ to set a particular graphics mode (see gfxmode).

Depending on your kernel, your distribution, your graphics card, and the phase of the moon, note that using this option may cause GNU/Linux to suffer from various display problems, particularly during the early part of the boot sequence. If you have problems, set this variable to ‘text’ and GRUB will tell Linux to boot in normal text mode.

The default is platform-specific. On platforms with a native text mode (such as PC BIOS platforms), the default is ‘text’. Otherwise the default may be ‘auto’ or a specific video mode.

This variable is often set by ‘GRUB_GFXPAYLOAD_LINUX’ (see Simple configuration).


But more importantly: I found the message error: no video mode activated you get on Bug 699802 and it has a possible solution:

Decommenting #GRUB_GFXMODE=640x480 in /etc/default/grub actually solves the problem. Remember to run sudo update-grub after changing /etc/default/grub.

Also look at comment 27 and also comment 24 and 30 as interesting workarounds. Comment 30:

Just wanted to confirm that the method for number 24 works well for people with the encrypted partition (don't bother with the uncommenting stuff). Just so anyone like myself out there doesn't have to look all over to figure out how to do simple commands (my first time ever using linux). Launch the terminal and go to the directory cd /usr/share/grub/ . Copy the font files to another directory (cp, needs sudo, and *.pft copies the three font files at once) with sudo cp *.pf2 /boot/grub then update grub with sudo update-grub.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.