Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This problem has me stumped, but I am sure someone out there has some ideas...

On my desktop machine, I have 2 DVD drives. Both are ATA drives. One is a DVD-RW DL; the other is just a DVD ROM. Under both Ubuntu 10.04 and 10.10 I am seeing the same symptoms from both drives.

When I first boot the system, the drives seem to run normally. I can watch DVDs with no problem from mplayer, vlc, and even MythTV. If I leave the machine running for several hours (say over night), and try to access the DVD drives in the morning, they are very, very slow (transfer rates in 10's of kBytes, not Mbytes). If I then reboot the machine, things go back to normal.

When the drives slow down, other function on the machine seem to be running with no problems or slowdown. Looking at htop and iotop don't show any amount of unusual activity. I have looked in dmesg and syslog, but nothing seems to out of the ordinary. I have tried enabling and disabling DMA for the drives.

The searching I have done on the internet suggests that some others have seen the problem. In some cases, upgrading to the 2.6.36 (or later) kernel has seemed to help, and in some cases it hasn't. (BTW, I am currently running the latest 10.10 official kernel on the machine.)

Does anyone have any ideas or suggestions on what to look at?

--- Update 2011-09-04 ---

So, inspired by Sebastian's comment, I decided to write a simple script to log a time stamp, the test DVD ROM Speed (hdparm -tT /dev/sr0), the hd settings for the cdrom, and the running process to a log file. The script has been running for over a day, and the DVD ROM is also still running quite happily and quickly. The machine has also been on for over 2 days. It looks like a quantum problem -- as soon as you observe it, it goes away.

I also made one other change since last booting, so maybe it had something to do with it. The USB mouse I had been using started periodically not working. It would just freeze up. This was both in Gnome and KDE. I removed that mouse from the system and installed a new USB mouse. Now the mouse is working fine. Perhaps the problems with the old mouse were causing secondary effects. (I know, it sounds like a long shot.)

share|improve this question
    
If you are running Lucid - you can now install kernel 2.6.38 from synaptic - just search for 2.6.38 and install the kernel header and image files shown. –  fossfreedom Sep 13 '11 at 14:42
    
@fossfreedom The machine's running Maverick now, but I'll check tonight and see if 2.6.38 is available. Thanks. –  jwernerny Sep 13 '11 at 14:57
    
I dont think 2.6.38 was backported for Maverick - its definitely available for Lucid since I have a laptop running with 2.6.38. You could try the 2.6.36 maverick tagged kernel from here kernel.ubuntu.com/~kernel-ppa/mainline –  fossfreedom Sep 13 '11 at 15:03
add comment

1 Answer

up vote 2 down vote accepted

If no one know the solution I think that maybe doing the following ones when the dvd drive is fast and ones when the dvd drive is slow maybe helps you:
sudo hdparm -i /dev/sr0

It could also not help you. We will see. :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.