Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Im trying to configure my Lucid 10.04.03 in order to work with Sip phones;

Actually, Ekiga and Jitsi* works fine, except for the call transfer/forward, that is very important for me.

With Ekiga, i press first H to hole, then T to transfer, then the number of a my colleague, but nothings happen.

With Jitsi, i get an "not implemented" error, lose the call and keep the sip account busy for about 30 seconds (strange thing is that jitsi should implement the transfer in the last stable version, but i tryed both the nighly and the stable)

Twinkle, Linphone, QuteCom; I've tryed them all but noone works with transfer/forward.

Any idea?

p.s: I'll love to get jitsi work becose it support even gtalk/jabber, so i can have 1 app to all my contacs.

UPDATE From the Twinkle manual:

When you want to transfer a standing call to another party you press the Xfer button. This will popup a dialog box from which you can choose what kind of call transfer you want.

Blind call transfer Transfer with consultation Transfer to other line

Call transfer will only work if your SIP provider and/or the remote party supports the proper SIP extensions.

this could be the reason why my xfer button is disabled, but my colleagues can transfer call without problem, they're using X-Lite on MacOsx, so i guess my sip does support call transfer...

share|improve this question
    
Do you still have the problem. Have you found how to solved the problem or considered accepting an answer that solves your problem (if any)? –  Luis Dec 5 '11 at 18:57
    
nope, still not able to transer calls - im not using voip software nomore. –  Strae Dec 5 '11 at 23:34

1 Answer 1

up vote 4 down vote accepted

I didn't try the others recently but I have twinkle working very well here with call transfer since 2007 on many machines. Does your PBX (or sip provider) is configured/allow call transfer?

Update:

Transferring with twinkle:

1) Attended transfer:

1 Press Hold
2 Select the free line
3 Call inernal number and talk to colleague
4 Press Bye (and your colleague also needs to shutdown the call)
5 Do Blind transfer (next item) if OK to transfer or talk with caller

2) Blind transfer

1 Press XFer, enter internal number and select Blind Tranfer
2 Press OK

The problem with blind transfer is that if the destination is not available, the external call is lost. This happens with all softphones I tried but I guess you can change that doing some work on Asterisk if you are using it as PBX.

share|improve this answer
    
Yes, in my office im the only one unable to transfer calls, my 3 collegues running Mac OSX with X lite doesnt have any problem.. With Twinkle, when you transfer the call, do you put just the internal number or some other things? –  Strae Sep 13 '11 at 14:03
    
Just reinstalled twinkle, but looks like i cant use the Transfer option; There is somethings that i have to configure? –  Strae Sep 13 '11 at 14:07
    
Attended transfer option doesn't work but I updated the answer with the way I do it. Blind transfer option works without any config or special code, only the internal number –  laurent Sep 13 '11 at 16:39
    
Really thanks for your help! But in my case, the XFer button is never active, not even when holding a call: goo.gl/II1l8 I have no idea on how to enable it.. –  Strae Sep 14 '11 at 7:02
    
Maybe you have something wrong configured. Try to look in User Profile -> Sip Protocol -> REFER tab. (I have checkboxes 1, 2 and 4 selected only) –  laurent Sep 14 '11 at 18:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.