Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed 11.10 beta when it was released a couple of weeks ago. Everything is working fine.

Later I installed gnome shell and then upgraded it from the gnome-shell testing ppa. I also installed and enabled all the gnome-shell-extensions available on the ppa. There is only one problem. When ever I switch to a theme which has a transparent gnome-shell menu I see nautilus menu behind it. It only disappears when I quit nautilus. I don't know I to get rid of it so that I can use use themes like Nord and Malys properly.

Here is a screenshot:

enter image description here

share|improve this question
what ppa is that? – RolandiXor Sep 12 '11 at 18:11
Would you provide a screenshot? – desgua Sep 12 '11 at 19:35
@desgua: here's a screenshot: – Alin Andrei Sep 12 '11 at 20:56
This is the gnome-shell testing ppa for oneiric "ppa:ricotz/testing" – Syed Khalil Sep 14 '11 at 9:07
up vote 1 down vote accepted

That actually happens with the official Gnome Shell packages in Ubuntu 11.10 too (at least for me, at the time I'm posting this answer).

I only know a fix for this: disabling Nautilus from handling the desktop (so using this, you won't have icons on the desktop anymore). To do this, install "dconf-tools":

sudo apt-get install dconf-tools

Then launch "dconf-editor", navigate to org > gnome > desktop > background and uncheck the "show-desktop-icons" box.

share|improve this answer
Thanks buddy, I used gnome-tweak-tool to disable nautilus from handling the desktop and now it works – Syed Khalil Sep 13 '11 at 1:55

AFAIK this is a bug in nautilus that occurs when ever there is no window manager running, and apparently also happens in GNOME Shell. I'm still trying to figure out myself what triggers it specifically, so I can report a bug with the correct details.

I believe it is probably already noticed by the developers however.

Hopefully, as 11.10 is still not at a final release, this bug should be fixed by the release date.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.